DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2874780 - Last Review: August 5, 2013 - Revision: 2.0

Symptoms

Software that is installed on computers is successfully brought over to Microsoft System Center 2012 Service Manager through the Configuration Manager connector. However, when you uninstall the software from a computer and then perform a hardware inventory in System Center 2012 Configuration Manager Service Pack 1 (SP1), the software-installed relationship is not removed in Service Manager even though the relationship is successfully removed in Configuration Manager.

Cause

The Service Manager connector to Configuration Manager uses software-deletion records to remove the software-installed relationship. However, a change that was introduced in System Center 2012 Configuration Manager SP1 prevents these deletion records from being written. 

Resolution

To resolve this issue, re-enable the triggers that write the deletion records in Configuration Manager. Then, the Service Manager connector will be able to successfully recognize and perform the associated action to remove the software-installed relationship.

To do this, go to the following Microsoft Developer Network (MSDN) website, and use the stored procedure that is described there:

How to Enable and Disable Extraction Views (http://msdn.microsoft.com/en-us/library/hh949655.aspx)

Applies to
  • Microsoft System Center 2012 Service Manager Service Pack 1
  • Microsoft System Center 2012 Service Manager
  • Microsoft System Center 2012 Configuration Manager Service Pack 1
  • Microsoft System Center 2012 Configuration Manager
Keywords: 
KB2874780
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support