DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 297684 - Last Review: November 23, 2010 - Revision: 7.1

This article was previously published under Q297684

On This Page

SYMPTOMS

On a computer that runs one of the versions of Windows that is listed at the beginning of this article, if you map a drive to a network share, the mapped drive may be disconnected after a regular interval of inactivity, and Windows Explorer may display a red "X" on the icon of the mapped drive. However, if you try to access or browse the mapped drive, it reconnects quickly.

CAUSE

This behavior occurs because the systems can drop idle connections after a specified time-out period (by default, 15 minutes) to prevent wasting server resources on unused sessions. The connection can be re-established very quickly, if required.

RESOLUTION

To have us change the default time-out period for you on the server side, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.


NOTE: You cannot change the default time-out period for Microsoft Windows 95-based computers and Microsoft Windows 98-based computers that have shared resources.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50494


Notes
  • You should run the Fix it solution on the computers that have shared resources.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not using the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To resolve this behavior, change the default time-out period on the shared network computer. To do this, use one of the following methods.

Registry Editor

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Use Registry Editor to increase the default time-out period. To do this, follow these steps, and then quit Registry Editor:

NOTE: You cannot use this method to turn off the autodisconnect feature of the Server service. You can only use this method to change the default time-out period for the autodisconnect feature.
  1. Click Start, click Run, type regedit (Windows 2000 or Windows Server 2003) or type regedt32 (Windows NT 4.0), and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
  3. In the right pane, click the autodisconnect value, and then on the Edit menu, click Modify. If the autodisconnect value does not exist, follow these steps:
    1. On the Edit menu, point to New, and then click REG_DWORD.
    2. Type autodisconnect, and then press ENTER.
  4. On the Edit menu, click Modify.
  5. Click Hexadecimal.
  6. In the Value data box, type ffffffff, and then click OK.
NOTE: The client-side session is automatically disconnected when the idling time lasts more than the duration that is set in KeepConn. Therefore, the session is disconnected according to the shorter set duration value between AutoDisConnect and KeepConn. To change the time-out duration in the client-side during a UNC connection, specify the arbitrary time in KeepConn.
Locate and then click the following key in the registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\lanmanworkstation\parametersValue: KeepConn
Data type : REG_DWORD
Range : 1 to 65535 (sec)
Default value: 600 sec = 10 mins

Command Line

NOTE: If you use this method, you may turn off the autotuning feature for the Server service.

To change the default time-out period for the autodisconnect feature of the Server service, open a command prompt, type the following line, and then press ENTER
net config server /autodisconnect:number
where number is the number of minutes that you want the server to wait before it disconnects a mapped network drive. The maximum value for this command is 65,535.

NOTE: If you set the autodisconnect value to 0 (zero), the autodisconnect feature is not turned off, and the Server service disconnects mapped network drives after only a few seconds of idle time.

To turn off the autodisconnect feature, open a command prompt, type the following line, and then press ENTER:
net config server /autodisconnect:-1

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) .

MORE INFORMATION

Some earlier programs may not save files or access data when the drive is disconnected. However, these programs function normally before the drive is disconnected.

For additional information about how to increase the default time-out period, click the following article numbers to view the articles in the Microsoft Knowledge Base:
138365  (http://support.microsoft.com/kb/138365/EN-US/ ) How Autodisconnect Works in Windows NT and Windows 2000
128167  (http://support.microsoft.com/kb/128167/EN-US/ ) Server Service Configuration and Tuning

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Service Pack 3
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 Enterprise
  • Windows 7 Enterprise
Keywords: 
kbenv kbprb kbfixme kbmsifixme KB297684
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support