DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 299795 - Last Review: September 3, 2012 - Revision: 4.0

 
This article was previously published under Q299795
For a Microsoft Visual Studio .NET version of this article, see
325004  (http://support.microsoft.com/kb/325004/EN-US/ ) HOW TO: Author MSDE 2000 Setup Packages by Using Visual Studio .NET

On This Page

Summary

Microsoft SQL Server 2000 Desktop Engine (MSDE 2000) provides Merge Modules to provide flexibility for a developer to be able to consume the merge modules into his/her setup product. This article documents detailed steps about how to put together a simple MSDE 2000 setup package from MSDE 2000 merge modules by using Microsoft Visual Studio Installer 1.1.

More information

Use these steps to create a simple MSDE 2000 setup package from MSDE 2000 merge modules with Microsoft Visual Studio Installer 1.1:
  1. Download Visual Studio Installer 1.1 (VSI) from: http://msdn.microsoft.com/en-us/vstudio (http://msdn.microsoft.com/en-us/vstudio)
  2. Install Visual Studio Installer 1.1 onto your local computer.
  3. Open Microsoft Visual Studio Installer 1.1.NOTE: You need the Microsoft Visual Studio product ID to download VSI 1.1. From the Help menu, click About. The product ID appears in the About dialog box.

  4. Click to select New Project.
  5. Click to select Visual Studio Installer 1.1 Projects.
  6. Click to select Empty Installer.
  7. Give the project a name and location, and then click OK.
  8. Navigate to the Project menu, and then click Add Merge Module(s).
  9. Add all of the merge modules from SQLMSDE\MSM.
  10. Navigate to the Project menu, and then click Add Merge Module(s). Add all of the merge modules in SQLMSDE\MSM\1033.
  11. Click Build Menu, and then click Build to build the package. You must use Orca.exe to change the ProductLanguage in the Property table from 0 to 1033. For some MSDE custom actions, you must set the ProductLanguage property to a specific language ID such as 1033 for the setup to work. For additional information about how to use Orac.exe, click the article number below to view the article in the Microsoft Knowledge Base:
    255905  (http://support.microsoft.com/kb/255905/EN-US/ ) HOWTO: Use Orca to Edit Windows Installer Files

Important Note

If you ever installed the Microsoft Windows Installer SDK 1.5 beta, you may experience problems with error messages similar to:
The install dialog Welcome is invalid.

The install dialog Select Installation Folder is invalid.

The install dialog Confirm Installation is invalid.

The install dialog Progress is invalid.

The install dialog Finished is invalid.

The install dialog Fatal Error in Installation is invalid.

The install dialog User Interrupted installation is invalid.

The network install dialog Welcome is invalid.

The network install dialog Select Network Location is invalid.

The network install dialog Progress is invalid.

The network install dialog Finished is invalid.

The network install dialog Fatal Error in Installation is invalid.

The network install dialog User Interrupted Installation is invalid.

The network install dialog Error Dialog is invalid.
If you had installed the Microsoft Windows Installer SDK 1.5 beta and one of the preceding error messages occurs, see the following article in the Microsoft Knowledge Base to resolve the issue:
281650  (http://support.microsoft.com/kb/281650/EN-US/ ) BUG: Cannot Compile VSI Project - "Install Dialog" Errors
Keywords: 
kbinfo KB299795
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support