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Article ID: 304572 - Last Review: February 28, 2014 - Revision: 3.8

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SYMPTOMS

When you use a SMART IOCTL call to an IDE hard disk that is configured as a slave to a non-smart ATAPI master device, the call may not work correctly. If you are using third-party software to monitor the health of the computer's smart hard disk and it is configured as a slave to a non-smart ATAPI device, the software may not be aware of the drive at all.

CAUSE

This problem can occur when an ATAPI device (such as a CD-ROM drive) that does not support SMART IOCTL calls is configured as a master IDE device. This is because the SMART IOCTL call references a master device TargetID in a SCSI Request Block, which is always returned as zero (0).

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size    File name
   ----------------------------------------------------
   Sep-11-2001  16:45  5.0.2195.4324  86,768  Atapi.sys
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173  (http://support.microsoft.com/kb/265173/ ) The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:
296861  (http://support.microsoft.com/kb/296861/ ) Use QChain.exe to Install Multiple Hotfixes with One Reboot
For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the following article number to view the article in the Microsoft Knowledge Base:
249149  (http://support.microsoft.com/kb/249149/ ) Installing Microsoft Windows 2000 and Windows 2000 Hotfixes
The Microsoft Windows 95 and Windows NT SMART IOCTL API specification is available at the following Microsoft Web site:
http://www.microsoft.com/whdc/default.mspx (http://www.microsoft.com/whdc/default.mspx)

APPLIES TO
  • Microsoft Windows 2000 Server SP1
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbbug kbenv kbfix kbqfe kbwin2000presp3fix kbwin2000sp3fix KB304572
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