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Article ID: 313147 - Last Review: January 11, 2015 - Revision: 1.0

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Symptoms

When the GetNtmsObjectAttribute function is called and the buffer is too small, an ERROR_INSUFFICIENT_BUFFER error is returned with the wrong value.

Cause

The array in the GetNtmsObjectAttribute call, is defined as a conforment array. When the API is called, the array size is set at runtime as to what the caller sets it to. When the server side sets the size to a higher value for the return argument, the RPC runtimes determine that it is an out-of-bounds error.

Resolution

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to Obtain the Latest Windows XP Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this fix should have the following file attributes or later:
   Date         Time     Version      Size     File name
   -------------------------------------------------------
   14-Feb-2002  12:42pm  5.1.2600.28  165,888  Ntmsdba.dll
   14-Feb-2002  12:42pm  5.1.2400.28   38,400  Ntmsapi.dll
   14-Feb-2002  12:42pm  5.1.2400.28  396,288  Ntmssvc.dll
				

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

Applies to
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbenv kberrmsg kbfix kbsysadmin kbWinXPsp1fix KB313147
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