DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 318358 - Last Review: October 27, 2006 - Revision: 1.2

Hotfix Download Available
View and request hotfix downloads
 
This article was previously published under Q318358

SYMPTOMS

If you swap a CardBus card after your computer resumes from suspend, your computer may stop responding (hang).

This problem occurs with any PC Card device that displays a Power Management tab in its properties. If the Allow this device to bring the computer out of standby check box in the device's properties is selected, your computer may hang when you swap PC Card devices after suspending and resuming your computer.

CAUSE

This behavior is caused by a problem in Pcmcia.sys.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to Obtain the Latest Windows XP Service Pack
The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size     File name
   ----------------------------------------------------
   12-Mar-2002  18:11  5.1.2600.37  115,584  Pcmcia.sys
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.

MORE INFORMATION

When you stop the 32-bit Cardbus device by using the Safely Remove Hardware tool in Windows XP, the power (VCC) for that device is not turned off. This behavior is by design on Windows XP, and is a limitation in the existing design of Windows. Because of the integration of the PCI driver and the PCMCIA driver, power cannot be turned off, otherwise the PCI configuration on the bus is lost.

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kboswin2000fix kbwinxpsp1fix KB318358
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support