DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 320289 - Last Review: February 1, 2007 - Revision: 3.4

This article was previously published under Q320289

SYMPTOMS

When you click a link to a Tagged Image File Format (TIF, TIFF) image in Internet Explorer, you may be prompted to either open the file directly or save the file. Note that this may occur even though you previously clicked to clear the Always ask before opening this type of file check box. Also note that the issue that is described in this article is specific to users who previously clicked to clear the Always ask before opening this type of file check box.

CAUSE

In the Registry, both TIFImage.Document (the default ProgID for the .tif and .tiff file extensions) and Imaging.Document point to the same CLSID. However, this CLSID only refers back to one ProgID (which is Imaging.Document).

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

To resolve this issue, use Registry Editor to view the following registry subkey:
HKEY_CLASSES_ROOT\.tif
In the right pane of Registry Editor, right-click (Default), and then click Modify. In the Value data box, type the following value, and then click OK:
Imaging.Document
Use Registry Editor to view the following registry subkey:
HKEY_CLASSES_ROOT\.tiff
In the right pane of Registry Editor, right-click (Default), and then click Modify. In the Value data box, type the following value, and then click OK:
Imaging.Document
Quit Registry Editor.

IMPORTANT: If you use a graphics viewer that supports Tagged Image File Format (TIFF) files (for example, Microsoft Imaging in Windows 2000), then any of the registry values that are listed in the "Cause" section may be changed. As a result, this problem may reoccur.

APPLIES TO
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Keywords: 
kbenv kbprb kbui KB320289
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support