DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 320694 - Last Review: December 24, 2014 - Revision: 6.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

Symptoms

Some 16-bit programs such as Edit.com and Debug.exe do not update the screen in a timely fashion on computers with a clock speed over 2.0 GHz. If you move the mouse pointer over the window, you see an update occur.

Cause

The timer interval is calculated in a way that wraps for fast processors.

Resolution

Microsoft Windows 2000

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/EN-US/ ) How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   17-Apr-2002  19:57  5.0.2195.5589  396,560  Ntvdm.exe
				

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to Obtain the Latest Windows XP Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size     File name
   ---------------------------------------------------
   17-Apr-2002  17:25  5.1.2600.42  395,264  Ntvdm.exe   
				

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Windows XP Only

This problem was first corrected in Windows XP Service Pack 1.

Windows 2000 Only

This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

Applies to
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kbappcompatibility kbbug kbfix kboswin2000fix kbwinxpsp1fix KB320694
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support