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Article ID: 322141 - Last Review: February 27, 2014 - Revision: 3.7

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SYMPTOMS

A member of an FRS-replicated DFS root or link that is using the Q307319 or Q321557 releases of the Ntfrs.exe file may accumulate staging files. This may occur if the member is configured without any outbound connection objects. This type of member is referred to as a "leaf member". SYSVOL replica sets use Active Directory replication topology that inherently has at least one outbound connection object.

CAUSE

When a file is modified in an FRS-replicated tree, FRS builds a compressed version of the file, called a staging file, which is propagated to direct downstream partners. In typical operation, staging files are deleted when all downstream partners receive a change. The Q307319 and Q321557 releases of FRS added two enhancements to staging file management.

To enhance performance, FRS was modified to retain change orders in the outbound log, and their corresponding staging files. This behavior occurs even after they were sent to all outbound partners, or if there are no current outbound partners. NTFRS can synchronize with a new partner that is added to the replica set or that added an inbound connection object from a member computer without having to perform a full scan of the IDTable and regenerate the staging files.

To avoid keeping the outlog change orders forever, a parameter was added that controls the outlog change-order-retention period. Periodically, NTFRS scans the tail of the outlog, and then deletes any change orders that have exceeded this retention period. The related staging file is also deleted.

A regression in Q307319 and Q321557 causes FRS to not enter the cleanup code for the change order records in the outbound log. The outbound log is cleaned up when you stop or start the service, but otherwise it accumulates change orders over time.

The staging folder on a busy replica can become very large. If the disk or staging folder that contains the FRS database fills up, the service posts an event log message and stops.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/EN-US/ ) How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   07-Aug-2002  22:39  5.0.2195.6002  733,968  Ntfrs.exe        
   09-Oct-2002  18:04  5.0.2195.6007   54,544  Ntfrsapi.dll     
   09-Oct-2002  18:04  5.0.2195.6002   21,264  Ntfrsprf.dll     
   07-Aug-2002  22:39  5.0.2195.6002   80,384  Ntfrsres.dll     
   03-Oct-2002  21:45  5.0.2195.6078  513,616  Ntfs.sys
				

WORKAROUND

To work around this problem, configure all members of a set with at least 1 outbound partner or stop and then restart the service to start the outlog clean-up code.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about related topics, click the article numbers below to view the articles in the Microsoft Knowledge Base:
307319  (http://support.microsoft.com/kb/307319/EN-US/ ) Changes to the File Replication Service
321557  (http://support.microsoft.com/kb/321557/EN-US/ ) Improvements in the Post-SP2 Release of Ntfrs.exe That Is Packaged with an Updated Ntfs.sys Driver
For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173  (http://support.microsoft.com/kb/265173/EN-US/ ) The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:
296861  (http://support.microsoft.com/kb/296861/EN-US/ ) How to Install Multiple Windows Updates or Hotfixes with Only One Reboot

APPLIES TO
  • Microsoft Windows 2000 Server SP1
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kbbug kbenv kbfix kboswin2000fix kbwin2000presp3fix kbwin2000sp3fix KB322141
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