DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 322811 - Last Review: February 27, 2014 - Revision: 3.4

Hotfix Download Available
View and request hotfix downloads
 
This article was previously published under Q322811
This article has been archived. It is offered "as is" and will no longer be updated.

On This Page

SYMPTOMS

A problem may occur when you install Internet Explorer by using the Microsoft Internet Explorer Administration Kit (IEAK) with the User Rights Deployment component. The installation may not work if both of the following conditions exist:
  • A non-administrator user logs on to the computer to complete the Internet Explorer installation.
  • The initial installation was started by an administrator.
When the non-administrator logs on, the following two error messages are generated:
Windows Update: The previous installation of an application has not been completed.

Logon with an administrator account to complete the installation.
If the non-administrator user closes the error message dialog boxes, the non-administrator user is immediately logged off of the computer. The non-administrator user cannot then log back on until an administrator logs on to the computer to complete the Internet Explorer installation.

CAUSE

This problem may occur if Windows Installer 2.0 is installed on the client computer before the IEAK User Rights Deployment installation is started.

RESOLUTION

Windows 2000

To resolve this issue, obtain and install Windows 2000 Service Pack 3 (SP3). For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/EN-US/ ) How to Obtain the Latest Windows 2000 Service Pack
The English version of this fix should have the following file attributes or later:
   Date         Time   Size     File name
   ----------------------------------------
   10-May-2002  10:51  139,786  Msimain.sdb
				

Windows XP

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to Obtain the Latest Windows XP Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 3 (SP3) and Microsoft Windows XP Service Pack 1 (SP1).

MORE INFORMATION

For additional information about a related problem in Microsoft Windows NT version 4.0, click the following article number to view the article in the Microsoft Knowledge Base:
319560  (http://support.microsoft.com/kb/319560/ ) Cannot install IEAK User Rights Deployment Build if MSI 2.0 was installed

APPLIES TO
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
  • Microsoft Windows XP Professional
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbenv kberrmsg kbfix kbsetup kbsysadmin kbwin2000sp3fix kbwinxpsp1fix KB322811
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support