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Article ID: 323597 - Last Review: March 1, 2007 - Revision: 2.5

This article was previously published under Q323597
Notice
This article applies to Windows 2000. Support for Windows 2000 ends on July 13, 2010. The Windows 2000 End-of-Support Solution Center (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fwin2000) is a starting point for planning your migration strategy from Windows 2000. For more information see the Microsoft Support Lifecycle Policy (http://support.microsoft.com/lifecycle/) .

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SYMPTOMS

When you try to connect from a Windows XP-based client to a Windows 2000-based Terminal Services server, the connection may not succeed and you may receive the following error message:
Because of a security error, the client could not connect to the terminal server. After making sure that you are logged on to the network, try connecting to the server again.
This error message may occur when you try to connect from a Windows XP-based client to some or all of the Windows 2000-based Terminal Services servers in your organization, or the error message may not occur at all.

When you try to connect from a Windows 2000-based client to a Windows 2000-based Terminal Services server, the following error may be logged on the Windows 2000 Teminal Server:
Event ID: 1003
Source: TermService
Type: Information
The terminal service client has provided an invalid license.

CAUSE

This error message is caused by a change in the certificates that are used by the Microsoft Clearinghouse to authorize Terminal Services Licensing servers.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

To resolve this problem, follow the steps in the following section on the affected Windows 2000-based Terminal Services servers and the Windows XP-based clients.

On the Terminal Services Server

  1. Start Registry Editor (Regedit.exe or Regedt32.exe).
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters
  3. In this registry key, delete the following values:
    Certificate
    X 509 Certificate
    X 509 Certificate ID
  4. Quit Registry Editor, and then restart the server.

On the Windows XP-Based Client

  1. Start Registry Editor (Regedit.exe).
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing
  3. Delete the whole MSLicensing key from the registry.
  4. Quit Registry Editor.
  5. Connect to the Terminal Services server.
NOTE: If these steps do no resolve the problem, you must deactivate and then reactivate the Terminal Services Licensing server. To do so, call the Microsoft Clearinghouse at 1-888-571-2048.

STATUS

Microsoft has confirmed that this is a problem in Windows 2000.

MORE INFORMATION

Because Windows XP Professional-based clients have a built-in Terminal Services Client Access License (CAL) for accessing Windows 2000-based Terminal Services servers, deleting the MSLicensing key on the client does not adversely affect license allocation in an organization.

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional
Keywords: 
kbenv kberrmsg kbprb KB323597
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