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Article ID: 326826 - Last Review: December 1, 2007 - Revision: 3.12

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This article was previously published under Q326826

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SYMPTOMS

Any program that uses files on a network share may seem to run slowly while the program is accessing large files across the network. The program may seem to take longer to start, or may seem to stop responding (hang) as it accesses large files across the network.

CAUSE

There is a problem with the redirector in which the redirector may remove a file from the cache although there are open handles to the file. This occurs when the redirector does not collapse an open call.

RESOLUTION

Windows 2000

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/EN-US/ ) How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
    Date         Time    Version        Size     File name 
    ---------------------------------------------------------- 
    05-Nov-2002  14:35   5.0.2195.6114  371,536  Mrxsmb.sys 
    05-Nov-2002  14:35   5.0.2195.6114  132,944  Rdbss.sys
				
Note This fix requires Windows 2000 Service Pack 3 (SP3).

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   23-Jan-2003  15:31  5.1.2600.1161     399,488  Mrxsmb.sys
   23-Jan-2003  15:31  5.1.2600.1161     154,880  Rdbss.sys


Windows XP 64-Bit Edition

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   23-Jan-2003  15:31  5.1.2600.1161   1,256,192  Mrxsmb.sys
   23-Jan-2003  15:31  5.1.2600.1161     489,088  Rdbss.sys
				
Note This fix requires Windows XP Service Pack 1 (SP1).

STATUS

Windows 2000

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

Windows XP

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about more recent redirector fixes for Windows 2000 and Windows XP, click the following article numbers to view the articles in the Microsoft Knowledge Base:
812937  (http://support.microsoft.com/kb/812937/EN-US/ ) File Lock or Access Denied Error Message When You Save Files Over the Network
816036  (http://support.microsoft.com/kb/816036/EN-US/ ) Windows 2000 Crashes with a "Stop 0x000000d1" Error Message
For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173  (http://support.microsoft.com/kb/265173/EN-US/ ) The Datacenter Program and Windows 2000 Datacenter Server Product

APPLIES TO
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Service Pack 3
Keywords: 
kbautohotfix kbhotfixserver kbqfe kboswin2000fix kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB326826
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