DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 330135 - Last Review: May 22, 2013 - Revision: 8.0

This article was previously published under Q330135

On This Page

Symptoms

When you insert a CD-ROM in the CD drive, the AutoPlay feature or the AutoRun feature may not work or may not be available. However, your CD drive may work correctly in every other way.

Cause

This issue may occur if one or more of the following conditions are true:
  • A version of Roxio Easy CD Creator that is earlier than version 5.02d is installed in your computer.
  • The AutoPlay feature is turned off in the registry.
  • Your CD-ROM drive is using an outdated driver.
  • The Restrict CD-ROM access to locally logged on user security option is turned on.
  • The CD drive is using an outdated driver.
  • The CD-ROM driver is not incompatible with Windows XP.

Resolution

To resolve this issue, follow the methods that are described in this section in the order in which they are presented until the issue is resolved.

You may find it easier to follow the steps if you print this article first.

Method 1: Determine which version of Easy CD Creator is installed on your computer, and then uninstall it

Note If Easy CD Creator is not installed on your computer, go to method 2.

Easy CD Creator version 5.02d and earlier versions can cause conflicts with the AutoRun or AutoPlay feature. To determine which version of Easy CD Creator is installed on your computer and uninstall it, follow these steps:
  1. Determine which version of Easy CD creator is installed on the computer. To do this, follow these steps:
    1. Start Easy CD Creator.
    2. On the Help menu, select About Easy CD Creator to see which version is installed on the computer.
    If the version installed is 5.02d or earlier, go to step 2 to uninstall it. If the version installed is later than version 5.02d, go to method 2.
  2. Uninstall Easy CD Creator using the Add or Remove Programs feature. To do this, follow these steps:
    1. Click Start, and then click Run.
    2. Type control appwiz.cpl in the Open box, and then press ENTER. The Add or Remove Programs window is displayed.
    3. Select Roxio Easy CD Creator from the list of currently installed programs, and then click Remove.
    4. Follow the instructions that appear on the screen to uninstall the program.
  3. Test to determine whether the issue is resolved.
If this method resolves the issue, you are finished.

If this method did not resolve the issue, go to method 2.

Method 2: Make sure that AutoPlay is turned on

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
The AutoPlay feature may not be turned on. To turn on AutoPlay, follow these steps:
  1. Click Start, and then click Run.
  2. Type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
  4. Double-click Autorun and see whether a zero or a one is displayed in the Value data box.
    • If the value for Autorun is 1, go to step 5.
    • If the value for Autorun is 0, right-click Autorun, and then click Modify. In the Value data box, type 1, and then click OK.
  5. Locate and then click the following subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
  6. Double-click NoDriveTypeAutoRun to see its value. If the value is 0xb5, the AutoRun feature for CD-ROMs is turned off. To turn on the AutoRun feature, follow these steps:
    1. Right-click NoDriveTypeAutoRun.
    2. Click Modify.
    3. In the Value data box, type 91.
    4. Select Hexadecimal, and then click OK.
  7. Exit Registry Editor.
Test to determine whether the issue is resolved. If the issue is resolved, you are finished.

If the issue is not resolved, go to method 3.

Method 3: Make sure that the CD-ROM is available only to users who are logged on locally

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
The Restrict CD-ROM access to locally logged on user only option might be turned off. To turn this option on, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  4. In the navigation pane, under Data, if the value for allocatecdroms is 0, go to step 5.
  5. In the navigation pane, under Data, if the value for allocatecdroms is 1, right-click allocatecdroms, and then click Modify.
  6. In the Value data box, type 0, and then click OK.
  7. Exit Registry Editor.
  8. Test to determine whether the issue is resolved.
If this method resolves the issue, you are finished.

If this method did not resolve the issue, go to method 4.

Method 4: Make sure that the CD-ROM driver is current

If the driver for the CD drive is not current, the AutoPlay feature may not work. To resolve this issue, follow these steps:
  1. Click Start, right-click My Computer, and then click Properties.
  2. On the Hardware tab, click Device Manager.
  3. In Device Manager, expand DVD/CD-ROM drives, and then right-click the CD drive that you want to update.
  4. Click Update Driver to start the Hardware Update Wizard, and then follow the instructions that appear on the screen to install the latest driver for the CD drive.
  5. Test to determine whether the issue is resolved.
If this method resolves the issue, you are finished.

If this method does not resolve the issue, go to method 5.

Method 5: Make sure that the CD drive is compatible with Windows XP

If the CD drive is incompatible with Windows XP, replace the CD drive with a compatible model. If the drive is compatible and the methods in this article did not help you, go to the “Next Steps” section.

More information

For additional information about a related topic, click the following article number to view the article in the Microsoft Knowledge Base:
314855  (http://support.microsoft.com/kb/314855/ ) CD-ROM may not run automatically in Windows XP
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

NEXT STEPS

If these methods did not help you, you might want to ask someone you know for help, or you can also use the Microsoft Customer Support Services Web site to find other solutions. Some services that the Microsoft Customer Support Services Web site provides include the following:
  • Searchable Knowledge Base (http://support.microsoft.com/search/?adv=1) : Search technical support information and self-help tools for Microsoft products.
  • Solution Centers (http://support.microsoft.com/select/?target=hub) : View product-specific frequently asked questions and support highlights.
  • Other Support Options (http://support.microsoft.com/default.aspx?pr=csshome) : Use the Web to ask a question, contact Microsoft Customer Support Services, or provide feedback.
If you continue to have problems, you might want to contact Support:
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

Applies to
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbexpertisebeginner kbexpertiseinter kbregistry kbenv kb3rdparty kbprb KB330135
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support