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Article ID: 812294 - Last Review: September 3, 2013 - Revision: 7.0

Symptoms

Replication may not occur for one server in a Microsoft Exchange organization. For example, the public folder hierarchy and the public folder contents do not replicate to or from a server that is running Microsoft Exchange Server 5.5, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or Microsoft Exchange Server 2003 Service Pack 1 (SP1).

If diagnostic logging has been enabled on the Exchange server, the following event will be logged in the Application log every time that the public information store is mounted:

Event Type: Warning
Event Source: MSExchangeIS Public Store
Event Category: Replication General
Event ID: 3002
User: N/A
Description: The replication agent is disabled for Public Folder Store "First Storage Group\Public Folder Store (CDF17)". For more information, click http://www.microsoft.com/contentredirect.asp.

Cause

This issue may occur if replication for the Messaging Database (MDB) on the server has been turned off.

You can turn off replication by setting the Replication registry entry to a value of 0. By default, replication occurs if this registry entry does not exist.

This issue may also occur in the following scenarios:
  • Remote procedure call (RPC) errors occur on another Exchange 2000 or Exchange 2003 server in the site. And, the Recipient Update Service does not stamp the proxyAddresses public information store object. After you restart the server that has RPC errors, the Recipient Update Service stamps the public information store object on the new server and replication occurs.
  • An invalid GatewayProxy address generator exists. And, the Enterprise Recipient Update Service does not stamp the proxyAddresses public information store object. After you remove the invalid GatewayProxy address generator and restart the Recipient Update Service server, the new public folder information store is stamped and replication works as expected.

Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows


To resolve this issue, delete the Replication registry entry for this MDB from the following subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public- <GUID of Public Store>
Note Do not delete the Replication registry entry if the following conditions are true:
  • You are using specific values for replication that are overriding the default values.
  • You want to continue to use these specific values.
You may want to compare this entry against working servers to verify that these servers do not have this entry set or to verify that this entry is set to a different value.

Use the following table to determine the decimal values for the Replication registry entry.
Collapse this tableExpand this table
ValueDescription
0Replication is disabled.
1Replication is enabled. (Use registry variable defaults. This has the same affect as deleting the entry.)
2Replication is enabled. (Use registry variable overrides.)
Note To enable the rest of the override settings for public folder replication, set the Replication registry entry to 2.

More information

If you are using Microsoft Exchange Server 2003 SP1 or earlier versions of Exchange, you can follow the steps in this article to resolve issues in public folder replication. We recommend that you upgrade to Microsoft Exchange Server 2003 Service Pack 2 (SP2) to benefit from the additional functionality that is available in this service pack.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
823817  (http://support.microsoft.com/kb/823817/ ) Exchange Server 2003 public folder administration improvements
For more information, see the Exchange Server 2003 SP2 Help file. You can download this file from the Microsoft Download Center.
The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download
Download the Exhelpupdate.msi package now. (http://www.microsoft.com/downloads/details.aspx?familyid=90BDB404-0F9B-4181-96FA-5871D9C26CF4&amp;amp;displaylang=en) Release Date: April 5, 2006

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

For more information about Exchange Server 2003 SP2, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/cc164305.aspx (http://technet.microsoft.com/en-us/library/cc164305.aspx)
For more information about issues that are fixed in Exchange Server 2003 SP2, click the following article number to view the article in the Microsoft Knowledge Base:
906669  (http://support.microsoft.com/kb/906669/ ) Issues that are fixed in Exchange Server 2003 Service Pack 2

Applies to
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange Server 5.5 Standard Edition
Keywords: 
kbtshoot kbreplication kbprb KB812294
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