DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 812937 - Last Review: December 1, 2007 - Revision: 5.5

Hotfix Download Available
View and request hotfix downloads
 

On This Page

SYMPTOMS

When you try to save a file such as a Microsoft Excel workbook that you opened by using a universal naming convention (UNC) path, you may receive an error message that is similar to one of the following:
Cannot read file. File is locked
Access Denied
Lock Error
Event Viewer may contain the following event:

Event Type: Information
Event Source: Application Popup
Event Category: None
Event ID: 26
User: N/A
Description: Application popup: Windows - Delayed Write Failed : Windows was unable to save all the data for the file name_of_the_file_you_want_to_save. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere. For more information, see Help and Support Center at http://support.microsoft.com.

CAUSE

This problem occurs when the redirector flushes the contents of the file, and writes to a file handle with read-only access instead of to a file handle with write access. When the redirector received an opportunistic lock break to none, it purged the cache for the file, but did not uninitialize the cache for the file. The redirector also needed to purge and uninitialize when the set end of file occurs because the opportunistic lock break is asynchronous. Because it did not uninitialize the cache for the file, it wrote to the incorrect file handle.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP SP1, Windows XP Tablet PC Edition

Date        Time  Version       Size      File name 
-------------------------------------------------------------- 
30-Jan-2003 21:41 5.1.2600.1164 400,896   Mrxsmb.sys 
30-Jan-2003 21:41 5.1.2600.1164 154,880   Rdbss.sys

Windows XP 64-Bit Edition

Date         Time  Version       Size      File name 
------------------------------------------------------------- 
30-Jan-2003  21:41 5.1.2600.1164 1,259,392 Mrxsmb.sys 
30-Jan-2003  21:41 5.1.2600.1164 489,216   Rdbss.sys

WORKAROUND

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
To work around this problem, disable opportunistic locking on the file server:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then press ENTER.
  3. In Registry Editor, locate the following subkey in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\LanmanServer\Parameters
  4. In the right pane, click EnableOplocks, and then press ENTER.
  5. In the Value data box, type 0, and then press ENTER.
  6. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about opportunistic locking, click the following article number to view the article in the Microsoft Knowledge Base:
296264  (http://support.microsoft.com/kb/296264/EN-US/ ) Configuring Opportunistic Locking in Windows 2000
A trace of this problem shows that the file is opened at least two times, and shows the system improperly writing to the read-only file handle. A trace that shows this problem is similar to the following:
96  CLIENT SMB: C NT create & X, File = \newshare.xls
           SMB: Desired Access = 0x00020089 
	  (Read Data,Read EA,Read Attributes)
97  SERVER SMB: R NT create & X, FID = 0x5
  	  SMB: Oplock Level = Batch

<content removed that displays the client program reading and locking the file, but the file is not closed>

450 CLIENT SMB: C NT create &amp; X, File = \newshare.xls
  	   SMB: Desired Access = 0x0002019F 
	   (Read/Write Data, Read/Write EA, Read/Write Attributes)

451 SERVER SMB: R NT create &amp; X, FID = 0xc007
	   SMB: Oplock Level = NONE

<content removed that displays the client program reading, locking,  writing and flushing data on this file handle>

585 CLIENT SMB: C write &amp; X, FID = 0x5, Write 0xc00 at 0x00005000
		PID = 0xFEFF TID = 0x1002 MID = 0x4400 UID = 0x0801
586 SERVER SMB: R write &amp; X - NT error, System, Error, Code = (34) STATUS_ACCESS_DENIED
Note The process identifier (PID) of 0xFEFF in frame 585 represents the client system process that is using the read-only file handle. It does not show the client program writing the data to disk.

APPLIES TO
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbenv kbqfe kberrmsg kbwinxppresp2fix kbfix kbbug KB812937
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support