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Article ID: 814560 - Last Review: August 29, 2007 - Revision: 4.2

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SYMPTOMS

A device that contains more than one interface descriptor is known as a composite USB device. Each interface in a composite USB device is numbered. When you attach a composite USB device whose interfaces are not sequentially numbered to a computer that is running Microsoft Windows XP, the composite USB device does not start.

CAUSE

This problem occurs because a new driver for composite USB devices that is included in Windows XP assumes that all composite USB devices have sequentially numbered interfaces.

If the interfaces are not sequentially numbered, the driver (Usbccgp.sys) does not find all the interfaces when the driver is selecting an initial configuration for the device. The initial configuration does not work when it is submitted to the USB driver stack because some of the interfaces are missing in the configuration request. This difference in the list of interfaces causes the Usbccgp.sys driver not to start the device.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date          Time     Version        Size     File Name     Platform
---------------------------------------------------------------------------
24-Feb-2003   14:03    5.1.2600.111   24,960   usbccgp.sys   Windows XP
21-Feb-2003   18:57    5.1.2600.1172  28,160   usbccgp.sys   Windows XP SP1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Service Pack 1a
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbprb kbusb KB814560
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