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Article ID: 816073 - Last Review: July 31, 2007 - Revision: 4.1

Hotfix Download Available
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For a Microsoft Windows Server 2003 version of this article, see 890553  (http://support.microsoft.com/kb/890553/ ) .
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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SYMPTOMS

When you try to compile a program on a Microsoft Windows XP-based computer, it may take approximately 30 percent to 40 percent longer to complete than it did when the same computer hardware was Microsoft Windows NT-based.

On a multihomed computer that is running Microsoft Windows XP, you may experience delays of between 10 and 60 seconds when you use Universal Naming Convention (UNC) paths to access files that are stored on a remote server message block (SMB) server. This problem occurs more frequently as your computer tries to access files more frequently. For example, the problem may occur when an application tries to access files at two-second intervals. The problem does not occur when you access the files through a mapped network drive. The problem also does not occur when NetBIOS over TCP/IP (NetBT) is disabled on at least one network interface.

CAUSE

This problem may occur if you compile a large program that has many files. Windows XP caches the files that you are compiling, and when the Windows cache limit is reached, Windows removes the files from the cache. When it does so, Windows may remove the files that are used frequently during the compilation. To use these files, you must cache them again. Recaching the files slows the compile process.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   --------------------------------------------------
15-Apr-2003 23:25 5.1.2600.1206 92,160 Cscdll.dll 
15-Apr-2003 22:59 5.1.2600.1206 401,920 Mrxsmb.sys 
15-Apr-2003 22:59 5.1.2600.1206 155,392 Rdbss.sys

				

WORKAROUND

To work around this problem, follow these steps:
  1. Map a network drive to the SMB server. To do this, follow these steps:
    1. Start Windows Explorer.
    2. On the Tools menu, click Map Network Drive.
    3. In the Drive list, click a drive letter.
    4. In the Folder list, type the UNC path of the shared resource on the server. Use the following format:
      \\ServerName\SharedItem
      Alternatively, click Browse, and then locate the shared resource.
    5. Click Finish.
  2. Disable NetBT on a network interface. To do this, follow these steps:
    1. Click Start, click Run, type ncpa.cpl, and then click OK.
    2. Right-click the network connection that you want to configure, and then click Properties.
    3. If the connection is a local area connection, click the General tab, click Internet Protocol [TCP/IP] in the This connection uses the following items box, and then click Properties. If the connection is not a local area connection, click the Networking tab.
    4. Click Advanced, and then click the WINS tab.
    5. In the NetBIOS setting area, click Disable NetBIOS over TCP/IP.
    6. Click OK three times.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.To successfully apply this hotfix, you must add the ScavengerTimeLimit value to the registry. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following key in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

    Min Value: 1 (time in seconds)
    Default Value: 10 Max Value: 120 (two minutes)
    Type: DWORD

    Note You can enter any value between 1 and 120 for the ScavengerTimeLimit to control how frequently the Scavenger thread cleans up old file share connections.
  3. Right-click Parameters, point to New, and then click DWORD value.
  4. Type ScavengerTimeLimit, and then press ENTER, to name the new value.
  5. Double-click ScavengerTimeLimit.
  6. In the Value data box, type 60, and then click OK.
  7. Close Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB816073
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