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Article ID: 816753 - Last Review: October 26, 2013 - Revision: 2.2

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SYMPTOMS

In Microsoft Exchange 2000 Server, you may find that the information store unexpectedly stops responding, and the messaging databases are dismounted. Additionally, the following events are logged to the application event log:

Source: MSExchangeIS
Category: Performance
Type: Warning
Event ID: 9582
Description:
The virtual memory necessary to run your Exchange server is fragmented in such a way that performance may be affected. It is highly recommended that you restart all Exchange services to correct this issue. For more information, click http://search.support.microsoft.com/search/?adv=1.

-and-

Source: MSExchangeIS
Category: Content Engine
Type: Error
Event ID: 12800
Description:
Message processing failed because there is not enough available memory (8007000E-8200022D). For more information, click http://search.support.microsoft.com/search/?adv=1.

Even though initial troubleshooting analysis indicates an out-of-memory condition, when you perform additional analysis, an access violation occurs.

CAUSE

This issue occurs because the OMSG::EcFlushProps function tries to flush a recipient object that has not yet been initialized when a low memory condition exists.

When the information store opens an existing message, an OMSG object is created. The initialization of the OMSG object is done by the OMSG::EcConfig2 function. The OMSG::EcConfig2 sets several properties. However, if a low memory condition exists when the OMSG::EcConfig2 function sets one of these properties, Exchange 2000 tries to flush the properties on the OMSG object before an out of memory error is reported. An access violation occurs when Exchange 2000 tries to flush a recipient object that has not yet been initialized.

RESOLUTION

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824282  (http://support.microsoft.com/kb/824282/ ) September 2003 Exchange 2000 Server post-Service Pack 3 rollup

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Component: Information store

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size    File name
--------------------------------------------------------
05-Jun-2003  23:13  6.0.6473.0   3,915,776  Cdoex.dll        
05-Jun-2003  23:08  6.0.6473.0     827,392  Davex.dll        
06-Jun-2003  01:08  6.0.6473.0     577,536  Dsaccess.dll     
05-Jun-2003  21:06  6.0.6473.0     184,320  Dscmsg.dll       
05-Jun-2003  23:13  6.0.6473.0   3,575,808  Excdo.dll        
06-Jun-2003  01:08  6.0.6473.0     258,048  Exmime.dll       
05-Jun-2003  23:08  6.0.6473.0   2,138,112  Exoledb.dll      
06-Jun-2003  01:06  6.0.6473.0      81,920  Exosal.dll       
05-Jun-2003  23:08  6.0.6473.0     307,200  Exprox.dll             
06-Jun-2003  22:11  6.0.6473.0     524,288  Madfb.dll        
05-Jun-2003  23:25  6.0.6473.0      49,152  Mdbevent.dll     
06-Jun-2003  01:04  6.0.6473.0   2,285,568  Mdbmsg.dll       
05-Jun-2003  23:26  6.0.6473.0      32,768  Mdbrole.dll      
06-Jun-2003  01:08  6.0.6473.0      24,576  Mdbtask.dll      
06-Jun-2003  01:07  6.0.6473.0   4,648,960  Store.exe        
 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbfix kbexchange2000presp4fix kbbug KB816753
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