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Article ID: 816982 - Last Review: October 26, 2006 - Revision: 2.5

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SYMPTOMS

After you install the hotfix that is documented in the following article in the Microsoft Knowledge Base article
329390  (http://support.microsoft.com/kb/329390/EN-US/ ) MS02-072: Unchecked Buffer in Windows Shell Might Permit System Compromise
on a computer with a high-speed hyper-threaded processor or multiple high-speed processors, a temporary folder may remain in the root folder of one of the computer's hard disks:

CAUSE

This problem occurs because the Windows Service Pack Setup installer (Update.exe) component that is included in the original installation package for the hotfix that is documented in Knowledge Base article
329390  (http://support.microsoft.com/kb/329390/EN-US/ ) MS02-072: Unchecked Buffer in Windows Shell Might Permit System Compromise
may not delete the temporary folders that it creates on computers with high-speed hyper-threaded processors or multiple processors.

For additional information about this problem, click the following article number to view the article in the Microsoft Knowledge Base:
817084  (http://support.microsoft.com/kb/817084/EN-US/ ) Installation of Hotfix Leaves a Temporary Folder on Hyper-Threaded or Multiprocessor Computers
The fix that is documented in this article repackages the hotfix with updated installer component files.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The repackaged hotfix that corrects the issue that is documented in Knowledge Base article
817084  (http://support.microsoft.com/kb/817084/EN-US/ ) Installation of Hotfix Leaves a Temporary Folder on Hyper-Threaded or
contains the updated components that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version   Size     File name
-------------------------------------------------
15-Feb-2003  01:20  5.3.16.3  411,136  Update.exe
The global version of this fix has the file attributes (or later) that are listed in the following table.
Date         Time   Version        Size     File name    SP level
------------------------------------------------------------------
21-Mar-2003  00:10  6.0.2600.105   126,464  Shmedia.dll  pre-SP1
21-Mar-2003  00:11  6.0.2800.1157  125,440  Shmedia.dll  pre-SP2
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

REFERENCES

For additional information about the unchecked buffer in Windows shell issue and hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
329390  (http://support.microsoft.com/kb/329390/EN-US/ ) MS02-072: Unchecked Buffer in Windows Shell Might Permit System Compromise

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB816982
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