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Article ID: 819636 - Last Review: February 27, 2014 - Revision: 5.2

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SYMPTOMS

A computer with the /3GB switch in the Boot.ini file and multiple small computer system interface (SCSI) controllers stops responding and a SYSTEM_PTE_MISUSE (0xDA) stop error occurs. This problem does not occur on a computer with one controller or a computer that does not have /3GB switch in the Boot.ini file.

CAUSE

This problem occurs because the SCSI port driver (Scsiport.sys) contains a code defect. During the enumeration of a SCSI controller, the SCSI port driver tries to acquire the resources that the SCSI adapter requires. If the resources are not available, the driver tries to release already-allocated resources and stops the enumeration process. While trying to free the resources, it de-references a memory location that was not allocated, and the computer stops responding.

RESOLUTION

Windows XP service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack

Hotfix information

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time  Version        Size   File name    Platform
   -------------------------------------------------------------
   02-May-2003 18:08 5.1.2600.1218  90,752 Scsiport.sys i386
   02-May-2003 18:08 5.1.2600.1218 305,920 Scsiport.sys IA64

Windows 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time  Version       Size   File name
   ---------------------------------------------------
   19-May-2003 18:40 5.0.2195.6745 74,192 Scsiport.sys 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Windows XP

This problem was first corrected in Microsoft Windows XP Service Pack 2.

APPLIES TO
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Service Pack 4
  • Microsoft Windows XP Professional
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbddk kbbug kbfix kbqfe kbwin2000presp5fix KB819636
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