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Article ID: 824847 - Last Review: February 27, 2014 - Revision: 1.6

This article has been archived. It is offered "as is" and will no longer be updated.

SYMPTOMS

When you visit a Web site that contains a link to a file that will be opened outside Internet Explorer, and the Web site also includes the VARY header in the response to the client GET request, you may receive the following error message when you click the link and then click Open:

Error:
Cannot open the file path of a temp file.

CAUSE

The VARY header instructs the client not to use a cached file. Therefore, Internet Explorer does not write the .chm file to the hard disk. HTML Help requires a file. The VARY header response from the server is similar to the following:
 "vary: accept-encoding, accept-language, cookie,
		  user-agent, translate"
Internet Explorer does not fully implement the VARY header per Requests for Comments (RFC) 2616. The Internet Explorer implementation of VARY is that it does not cache any data except for Vary-Useragent.

MORE INFORMATION

This problem is known to occur with HTML Help files (.chm files) and vCard files (.vcf files). Other programs that are not listed in the "Applies To" section of this article may also exhibit this problem. Programs that open files directly in Internet Explorer, such as Adobe Acrobat, do not exhibit this problem.

APPLIES TO
  • Microsoft Internet Explorer 6.0
  • Microsoft Internet Explorer 6.0 SP1
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
Keywords: 
kbnosurvey kbarchive kbprb KB824847
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