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Article ID: 828728 - Last Review: October 26, 2006 - Revision: 2.5

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SYMPTOMS

If you open the properties of a network interface connection and then click to clear a check box (such as the Network Monitor Driver or the File and Printer Sharing check box) and then click to select the same check box, the change may appear to work as expected after you click OK. However, you may not be able to connect to a network resource.

Note To change the properties of a network interface connection, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Network and Internet Connections.
  3. Click Network Connections.
  4. Right-click the network connection you want to change, and then click Properties.

CAUSE

This problem may occur if you are a member of both the Administrators group and the Network Configuration Operators group.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP, 32-Bit Version

   Date         Time   Version        Size     File name
   -------------------------------------------------------
   17-Sep-2003  17:59  5.1.2600.1271  584,192  Netcfgx.dll 

Windows XP, 64-Bit Version

   Date         Time   Version        Size       File name     Platform
   --------------------------------------------------------------------
   17-Sep-2003  17:35  5.1.2600.1271  1,843,712  Netcfgx.dll   IA-64
   17-Sep-2003  17:59  5.1.2600.1271    584,192  Wnetcfgx.dll  x86 

WORKAROUND

To work around this problem, your administrator can remove you from the Network Configuration Operators group if you are a member of the Administrators group.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB828728
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