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Article ID: 830511 - Last Review: November 1, 2005 - Revision: 2.5

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SYMPTOMS

When you press F1 after a Web page dialog appears, Microsoft Internet Explorer may unexpectedly quit, and you may receive the following access violation error message:
Internet Explorer has encountered a problem and needs to close. We are sorry for the inconvenience.

CAUSE

This problem may occur if the window.alert method generates the active window. For example, this problem may occur if you open a Web page that was created by using the following HTML code:
<html>
<body>
<input type="button" value="Click here" onclick="window.alert('Press F1');"/>
</body>
</html>

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   05-Feb-2004  15:14  6.0.2800.1403  1,339,904  Shdocvw.dll

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates

STATUS

Microsoft has confirmed that this is a problem in Internet Explorer 6. This problem was first corrected in Microsoft Windows XP Service Pack 2.

APPLIES TO
  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000
Keywords: 
kbhotfixserver kbqfe atdownload kbwinxpsp2fix kbwinxppresp2fix kberrmsg kbie600sp2fix kbie600presp2fix kbfix kbbug KB830511
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