DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 831805 - Last Review: March 19, 2007 - Revision: 2.3

SYMPTOMS

When your users try to connect to a Web site that has Web Distributed Authoring and Versioning (WebDAV) enabled, Microsoft Windows XP may not be able to verify WebDAV support.

CAUSE

This problem occurs when your users try to connect to a Web site whose address is something other than the root of the site. When the Windows XP WebDAV redirector issues an OPTIONS request to verify WebDAV support on the site, the request is in the following format:
OPTIONS / HTTP/1.1
host: Web_site
Typically, this format is correct for root-level access of a WebDAV-enabled site. However, when the user tries to connect to an address under the root address, the OPTIONS request must be in the following format:
OPTIONS /internal_path HTTP/1.1
host: Web_site
However, Windows XP does not use this format for WebDAV OPTIONS requests.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

REFERENCES

For more information, visit the following Microsoft Developer Network (MSDN) Web sites:
HTTP/Web Distributed Authoring and Versioning (WebDAV)
http://msdn2.microsoft.com/en-us/library/aa142661.aspx (http://msdn2.microsoft.com/en-us/library/aa142661.aspx)

WebDAV Notifications
http://msdn2.microsoft.com/en-us/library/aa142529.aspx (http://msdn2.microsoft.com/en-us/library/aa142529.aspx)

WebDAV Sample Application
http://msdn2.microsoft.com/en-us/library/ms878094.aspx (http://msdn2.microsoft.com/en-us/library/ms878094.aspx)

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kbnofix kbbug KB831805
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support