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Article ID: 831905 - Last Review: August 29, 2007 - Revision: 4.2

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SYMPTOMS

On your Microsoft Windows XP-based computer, the following failure event appears repeatedly in the security event log:

Source: Security
Type: Failure
Category: Privilege Use
Event ID: 577
Description:
Privileged Service Called:

Server: Security
Service: -
Primary User Name: PrimaryUserName
Primary Domain: PrimaryDomain
Primary Logon ID: PrimaryLogonID
Client User Name: ClientUserName
Client Domain: ClientDomain
Client Logon ID: ClientLogonID
Privileges: SeIncreaseBasePriorityPrivilege

You may experience slow response times and increased CPU use on your computer when the 577 events occur. If you log on to the Windows XP-based computer with an account that has local administrator credentials, you do not experience these symptoms.

CAUSE

This problem may occur when all the following conditions are true:
  • A program that is installed on your Windows XP-based computer makes a call to the SetProcessWorkingSetSize function to release the working set.
  • Auditing of the Audit privilege use category is turned on.
  • Your user account does not have the SeIncreaseBasePriorityPrivilege user right, also known as "Increase Scheduling Priority."
If these conditions are true, a program call to the SetProcessWorkingSetSize function to release the working set triggers audit event 577. The program call also triggers a second call to a function that requires the SeIncreaseBasePriorityPrivilege user right. This second call is unnecessary. When the SetProcessWorkingSetSize function triggers the second call, a false audit event 577 is logged to the security event log.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to obtain the latest Windows XP service pack

Hotfix information

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
    Date         Time   Version         Size       File name      Platform
    -----------------------------------------------------------------------
    10-Dec-2003  18:22  5.1.2600.1326   1,897,472  Ntkrnlmp.exe   x86
    10-Dec-2003  18:23  5.1.2600.1326   1,953,536  Ntkrnlpa.exe   x86
    10-Dec-2003  18:22  5.1.2600.1326   1,925,632  Ntkrpamp.exe   x86
    10-Dec-2003  18:22  5.1.2600.1326   1,930,496  Ntoskrnl.exe   x86

    10-Dec-2003  18:22  5.1.2600.1326   5,831,040  Ntkrnlmp.exe   IA-64
    10-Dec-2003  18:22  5.1.2600.1326   5,774,464  Ntoskrnl.exe   IA-64
Note This hotfix requires that you have Windows XP Service Pack 1.

Microsoft Windows 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Prerequisites
You must have Windows 2000 Service Pack 4 installed.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   08-Mar-2005  19:54  5.0.2195.7035     90,544  Mup.sys
   05-Jul-2005  04:58  5.0.2195.7058  1,714,560  Ntkrnlmp.exe
   05-Jul-2005  04:59  5.0.2195.7058  1,713,600  Ntkrnlpa.exe
   05-Jul-2005  04:59  5.0.2195.7058  1,735,936  Ntkrpamp.exe
   06-Jul-2005  06:50  5.0.2195.7059  1,690,944  Ntoskrnl.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

The SeIncreaseBasePriorityPrivilege user right permits a user to boost the scheduling priority of a process and to increase the working set of the process. This speeds up execution.

To free up the working set, a program can call the SetProcessWorkingSetSize function with both the minimum and the maximum size set to 0xffffffff. A program can also call the SetProcessWorkingSetSize function when the program will be idle for a long time or after the program completes an expensive task that has a big working set.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB831905
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