DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 832797 - Last Review: September 22, 2011 - Revision: 5.0

On This Page

SUMMARY

This article is a step-by-step guide about how to perform a mail merge in Microsoft Works 7.0 and Microsoft Works 8.0. Additionally, a video is provided later in this article to guide you through the mail merge.

Mail merge a Works Database file

To mail merge a Works database file, follow these steps.

Note These steps assume that you have already created a Works database file that you want to mail merge with, and that you have selected the records that you want included in your mail merge.
  1. Start Works.

    To do this, click Start, point to All Programs, and then click Microsoft Works Task Launcher.
  2. In Works Task Launcher, click Programs.
  3. In the Programs list, click Works Word Processor.
  4. In the tasks list, click Mail-merge documents.
  5. Click Start this task.

    The Works Word Processor will now start.
  6. In the Open Data Source dialog box, click Merge information from another type of file.
  7. In the Open Data Source dialog box, select your Works database file, and then click Open.

    Note The Insert Fields dialog box should now appear. At this point, your Works database file is attached to your mail merge main document.
  8. As appropriate, type the contents of your mail merge main document--for example, type the form letter.

    Put the cursor where you want your merge fields to appear. In the Insert Fields dialog box, select the field that you want, and then click Insert. Continue to select the fields that you want to insert, and then click Insert until you have all the fields that you want inserted.

    Note When you insert your fields, type the punctuation marks and the spaces between the fields, press ENTER to move to a new line, and then format the layout to appear as you want.
  9. After you have the fields inserted and formatted as you want, click View Results in the Insert Fields dialog box to view how your fields look.

    Note Use the View Results dialog box to view each record in the Works database file that you want.
  10. If the View Results do not correctly include the records that you have selected in your Works database file, point to Mail Merge on the Tools menu, and then click Filter and Sort.

    On the Filter tab, click Use Marked Records. Click OK to close the Filtering and Sorting dialog box.

    Note You can do some advanced filtering and sorting of your data file before you actually complete your mail merge to receive the results that you want. For help on the Filter and Sort tabs, click Help (?), and then click the area where you want more help.
  11. Click Close (X) to close the View Results dialog box.

Mail merge with your Works address book

To mail merge with your Works address book, follow these steps.

Note These steps assume that you already have your address book created in Works that you want to mail merge with.
  1. Start Works.

    To do this, click Start, point to All Programs, and then click Microsoft Works Task Launcher.
  2. In Works Task Launcher, click Programs.
  3. In the Programs list, click Works Word Processor.
  4. In the tasks list, click Envelopes.

    In this example, you mail merge your address list to envelopes. However, you can do a different mail merge with your Address List such as mailing labels or mail merge documents.
  5. Click Start this task.
  6. In the Envelopes dialog box, click Mail merge envelopes, and then click OK.
  7. In the Envelope Settings dialog box, select the envelope size that you want to use, and then click New Document.
  8. In the Open Data Source dialog box, click Merge from the Address Book.

    Note The Insert Fields dialog box should now appear. At this point, your Works address book is attached to your mail merge main document (your envelope).
  9. As appropriate, type the contents of your mail merge main document.

    For example, because you selected Envelopes in step 4, it is time to insert your merge fields into your envelope (mail merge main document). Put the cursor where you want your merge fields to appear, in the Insert Fields dialog box, select the field that you want, and then click Insert. Continue to select the fields that you want to insert, and then click Insert until you have all the fields that you want inserted. At the same time, type the punctuation marks and the spaces between each field that you insert. To move to the next line to layout your address fields, press ENTER.

    Note Do not forget to also type your return address as appropriate.
  10. After you have the fields inserted and formatted as you want, click View Results in the Insert Fields dialog box to view how your fields look.

    Note Use the View Results dialog box to view each record in the Works database file that you want.
  11. If the view results do not correctly include the addresses that you want in your address book, point to Mail Merge on the Tools menu, and then click Select Names.

    In the Select Names dialog box, select a name in your address book that you want, and then click Select to add that name to the Merge Recipients list. Click OK to close the Select Names dialog box.
  12. Click Close (X) to close the View Results dialog box.

Use a Works Spreadsheet file as a mail merge data source

  1. Start Works Word Processor.
  2. On the Tools menu, point to Mail Merge, and then click Open Data Source.
  3. In the Open Data Source dialog box, click Merge information from another type of file.
  4. In the Open Data Source dialog box, change the Files of Type to All Files. Then locate the Works Spreadsheet file that you want to use.
  5. Double-click the Works Spreadsheet file.
  6. In the Select File Type dialog box, click Microsoft Excel 8.0, and then click OK.
  7. Click the appropriate Yes or No regarding the first row as field names.
  8. In the Select Worksheet or Table dialog box, type SHEET1, and then click OK. Now, you will see the Insert Fields dialog box where you can insert the fields that you want in your merge document.

    Note The worksheet name SHEET1 is case insensitive and specific to US English. The following table lists the worksheet name for other languages:
    Collapse this tableExpand this table
    LanguageWorksheet Name
    BrazilianPlanilha
    CzechList
    DanishArk
    GermanBlatt
    GreekΦύλλο
    FinnishTaulukk
    FrenchFeuille
    HungarianLap
    PortugueseFolha
    ItalianFoglio
    Netherlands (Dutch)Blad
    NorwegianArk

Complete your mail merge

  1. On the File menu, click Print.
  2. If you viewed the results in your mail merge and noticed that blank lines were not suppressed, click to select the Don't print lines with empty fields check box.
  3. Use one of the following methods:
    • Click OK to complete your mail merge and to print your envelopes to the printer. If you select this option, the rest of the steps in this article may not apply.
    • To save your mail merge to a new document so that you can print later, click to select the Send merge result to a new document check box, and then click OK.
  4. A new document that contains your merged address list will now open. To save this file for printing later, click Save on the File menu.
  5. In the Save As dialog box, type a name for your new document in the File name box (for example, type My Envelopes) and then click Save.
This will create a new Works Word Processor document (*.wps) that contains all the pages (in this case, all your envelopes), and then you can print the documents later to complete your mailing.

View the Works mail merge video

To view a video about how to perform a mail merge, click the Play button on the Microsoft Windows Media Player viewer: Note To view this video, Microsoft Windows Media Player 7.0 or a later version must be installed on the computer. To obtain the latest version of Windows Media player, visit the following Microsoft Web site:
http://www.microsoft.com/windows/windowsmedia/download (http://www.microsoft.com/windows/windowsmedia/download)

APPLIES TO
  • Microsoft Works 7.0
Keywords: 
kbhowtomaster KB832797
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support