DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 833323 - Last Review: October 26, 2013 - Revision: 2.5

Hotfix Download Available
View and request hotfix downloads
 
This article has been archived. It is offered "as is" and will no longer be updated.

On This Page

SYMPTOMS

When a domain administrator uses Active Directory Users and Computers to reset the password for a user in a Microsoft Windows 2000 Server domain and selects the User must change password at next logon check box, the user can log on by using the new password. However, the user is not prompted to change the password.

CAUSE

This problem occurs because the user does not have the required minimum permission to set the User must change password at next logon setting. The required minimum permission is the Write Account Restrictions permission on user objects. When you delegate the ability to reset passwords, the only permission that is granted over the delegated container is the Reset Password permission on user objects.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   11-Feb-2004  22:18  5.0.2195.6897    468,752  Dsadmin.dll
   05-Feb-2004  20:18  5.0.2195.6896  5,869,056  Sp3res.dll

Additionally, after you apply this hotfix, you must use the Delegation of Control Wizard to grant Read and Write permissions to the user for the pwdLastSet attribute. To do this, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
  2. Right-click the Users container, or right-click the organizational unit where the user resides, and then click Delegate Control.
  3. Click Next.
  4. Click Add, select the user who must change the password, click Add, and then click OK.
  5. Click Next.
  6. Click Only the following objects in the folder, click to select the User Objects check box, and then click OK.
  7. Under Show these permissions, click to select the General check box.
  8. Under Permissions, click to select the Read check box, click to select the Write check box, and then click Next.
  9. Click Finish.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the naming schema for Windows software updates, click the following article number to view the article in the Microsoft Knowledge Base:
816915  (http://support.microsoft.com/kb/816915/ ) New file naming schema for Microsoft Windows software update packages
For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB833323
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support