DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 833436 - Last Review: July 24, 2007 - Revision: 3.12

Hotfix Download Available
View and request hotfix downloads
 

On This Page

SYMPTOMS

If you run the Dcdiag tool against a domain controller that is in a child organizational unit of the "Domain Controllers" organizational unit, you may receive an error report that is similar to the following:

Doing primary tests Testing server: Default-First-Site-Name\DC1W2K Starting test: MachineAccount * The current DC is not in the domain controller's OU ......................... DC1W2K failed test MachineAccount

Note In this error message, DC is domain controller and OU is organizational unit.

CAUSE

The problem may occur if domain controllers were moved from their original organizational unit to a child organizational unit of the "Domain Controllers" organizational unit. The "machineaccount" test of the Dcdiag tool performs a Lightweight Directory Access Protocol (LDAP) query with a scope that is set to LDAP_SCOPE_ONELEVEL to verify that the computer account of the domain controller is present in the "Domain Controller" organizational unit. If the domain controller is moved to a child organizational unit, the test fails.

RESOLUTION

Windows 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
  Date         Time   Version        Size     File name
  ------------------------------------------------------
  01-Dec-2003  20:16  5.0.2195.6826  217,872  Dcdiag.exe 


Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
  Date         Time   Version        Size     File name
  ------------------------------------------------------
  18-Mar-2004  00:49  5.2.3790.142  281,600  Dcdiag.exe
Note The Windows Support Tools for Windows Server 2003 Service Pack 1 contain an updated version of Dcdiag.exe that corrects the problem that is described in this Knowledge Base article. For more information about the Windows Support Tools for Windows Server 2003 Service Pack 1 and about how to obtain these tools, click the following article number to view the article in the Microsoft Knowledge Base:
892777  (http://support.microsoft.com/kb/892777/ ) Windows Server 2003 Service Pack 1 Support Tools

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915  (http://support.microsoft.com/kb/816915/ ) New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kberrmsg kbbug kbfix kbqfe kbwin2000presp5fix KB833436
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support