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Article ID: 834315 - Last Review: September 18, 2013 - Revision: 7.0

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Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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Symptoms

In a hosting environment where Microsoft Exchange Server 2003 computers are configured as offline address list servers, you may find that CPU usage by the Microsoft Exchange System Attendant service (Mad.exe) on each of the servers increases to 50 percent. You experience these symptoms even after you restart each server.

For example, you may experience these symptoms in a hosting environment where you have 10,000 offline address lists and 10 Exchange Server 2003 computers that are configured as offline address list servers.

Cause

This problem occurs in hosting environments where Exchange Server 2003 computers are configured as dedicated offline address list servers. This problem occurs in this type of hosting environment when the update schedule for offline address lists is set to Never run. The Microsoft Exchange System Attendant service uses an OABScan task to scan offline address lists that are generated on the server. This task is scheduled to run every 13 minutes and may increase CPU usage in the Microsoft Exchange System Attendant service to 50 percent. In a hosting environment that has this configuration, the OABScan task is not required.

Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993  (http://support.microsoft.com/kb/836993/ ) How to obtain the latest updates and service packs for Exchange Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Component: Exchange System Attendant

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
  Date         Time   Version       Size       File name
  ------------------------------------------------------
  20-Dec-2003  04:35  6.5.6980.58   8,765,440  Mad.exe 
Note Because of file dependencies, this hotfix requires Exchange Server 2003.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Exchange Server 2003 Service Pack 1.

More information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you apply the hotfix that is described in this article, you must edit the registry to activate the hotfix and to turn off the OABScan task.

To have us activate the hotfix for you , go to the "Fix it for me" section. If you prefer to activate the hotfix yourself, go to the "Let me fix it myself" section.

Fix it for me

To activate the hotfix automatically, which will set the Disable OABScanTask registry value to 1, click the Fix this problem link. Then, click Run in the File Download dialog box and follow the steps in this wizard.
Collapse this imageExpand this image
Fix this problem (http://go.microsoft.com/?linkid=9706527)
Microsoft Fix it 50337
Collapse this imageExpand this image

Note this Fix it solution works for all languages. However, for some languages, the wizard text may be in English

Note if you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Note When you set the Disable OABScanTask registry value to 1, you turn off the OABScan task. If you want to turn on the OABScan task, set the Disable OABScanTask registry value to 0 (zero) or remove the Disable OABScanTask registry value. After you do so, the following event is logged in the application event log to notify you that the task started:

Type: Information
Source: MSEXchangeSA
Category: General
Event ID: 9008
Description:

Microsoft Exchange System Attendant is starting 'Oabgen.dll'.

Let me fix it myself

To activate the hotfix yourself, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type Disable OABScanTask, and then press ENTER.
  6. Right-click the Disable OABScanTask registry value that you created in step 5, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Quit Registry Editor.
Note When you set the Disable OABScanTask registry value to 1, you turn off the OABScan task. If you want to turn on the OABScan task, set the Disable OABScanTask registry value to 0 (zero) or remove the Disable OABScanTask registry value. After you do so, the following event is logged in the application event log to notify you that the task started:

Type: Information
Source: MSEXchangeSA
Category: General
Event ID: 9008
Description:

Microsoft Exchange System Attendant is starting 'Oabgen.dll'.


Applies to
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Keywords: 
kbmsifixme kbfixme kbautohotfix kbqfe kbhotfixserver kbexchange2003sp1fix kbexchange2003presp1fix kbfix kbbug KB834315
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