DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 834427 - Last Review: June 26, 2009 - Revision: 6.1

On This Page

SUMMARY

The Remove Hidden Data add-in is a tool that you can use to remove personal or hidden data that might not be immediately apparent when you view the document in your Microsoft Office program.

You can run the Remove Hidden Data add-in on individual files from your Microsoft Office 2002 program or from your Microsoft Office 2003 program. Or, you can run the Remove Hidden Data add-in on multiple files at the same time from the command line. In either case, to run the tool you must have the program installed that you used to create the document.

Note The following dialog box appears in Word and in Excel when you open the files that were saved by using the Remove Hidden Data tool:
<file name> should be opened as read-only unless changes to it need to be saved. Open as read-only?
If you click Yes, the file will not be editable. If you click No, the file will be editable. This will enable new metadata to be entered.

For more information about the Remove Hidden Data add-in tool and about how to obtain it, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyId=144E54ED-D43E-42CA-BC7B-5446D34E5360 (http://www.microsoft.com/downloads/details.aspx?FamilyId=144E54ED-D43E-42CA-BC7B-5446D34E5360)
For more information about more known issues and topics that are not covered by the ReadMe file, click the following article numbers to view the articles in the Microsoft Knowledge Base:
834636  (http://support.microsoft.com/kb/834636/ ) Known issues with the Remove Hidden Data add-in for Office 2003 and Office XP
842684  (http://support.microsoft.com/kb/842684/ ) Known issues with the Remove Hidden Data add-in version 1.1 for Office 2003 and Office XP
To determine the version of the Remove Hidden Data tool that you have installed on your computer, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Add or Remove Programs.
  3. In the list of currently installed programs, click Remove Hidden Data Tool, and then click Click here for support information.
  4. Use the following table to determine the release version of the Remove Hidden Data tool that you have installed.
    Collapse this tableExpand this table
    Release versionVersion
    Remove Hidden Data Tool 1.111.0.6361.0
    Remove Hidden Data Tool 1.06.00.2600.0000
Note In the 2007 Microsoft Office system, the functionality of the Remove Hidden Data tool is built in to the application. To use this feature, follow these steps:
  1. With your file open, click the Microsoft Office Button, and then point to Prepare.
  2. Click Inspect Document. The Document Inspector dialog box appears. Notice that all items are selected. This means that all the listed checks will be performed automatically. If you want to skip any items in the list, click to clear the appropriate check boxes.
For more information about how to remove personal information in the 2007 Office system, click Help in Microsoft Office Word 2007, and then type inspect document in the Search box.

MORE INFORMATION

The following is the ReadMe file for the Remove Hidden Data add-in. This ReadMe file is located in the following folder after you install the Remove Hidden Data add-in:
path\Program Files\Microsoft Office\Remove Hidden Data Tool\1033

Microsoft Office 2003 ReadMe File: Remove Hidden Data add-in

© 2003 Microsoft Corporation. All rights reserved.

This document provides late-breaking information about the Microsoft Office 2003 Remove Hidden Data add-in. The Contents section lists all of the information contained in this file; for late breaking information specific to an individual Office system product, see the ReadMe file for that product.

Remove Hidden Data is an add-in for Microsoft Office 2003 Editions or Microsoft Office XP that lets users permanently remove hidden data and collaboration data from their Microsoft Word, Microsoft Excel and Microsoft PowerPoint files.

How to use this document

To view the ReadMe file on the screen, maximize the browser window. To print the ReadMe file, click the Print button on the toolbar.

Contents

Overview

When you distribute an Office document electronically, the document might contain information that you do not want to share publicly, such as information that allows you to collaborate on writing and editing the document, or hidden information that can be used to track who worked on the document.

The Remove Hidden Data add-in is a tool that you can use to remove personal or hidden information that might not be immediately apparent when you view the document in the Microsoft Office application.

You can run the Remove Hidden Data add-in on individual files from within the Office XP or Office System 2003 application. Or, you can run Remove Hidden Data on multiple files from the command line. In either case, the application that created the document must be installed in order for you to run the tool.

Notes

You should run the Remove Hidden Data add-in on files when you are ready to publish them. This is because some information removed by the tool is used by Office for collaboration features, such as Track Changes, Comments, and Send for Review, and these collaboration features will not work after using the Remove Hidden Data add-in.

The Remove Hidden Data add-in is designed to remove certain types of data from Office files permanently, automatically, and without prompting. By default, the add-in will prompt you to save the file to a new file name.

You should always save using a new file name, rather than overwrite the original file with the new document, in order to preserve a copy of the document containing the original data.

To change the language that the Remove Hidden Data add-in uses, you will need to uninstall the add-in and then download a new copy of the Remove Hidden Data add-in for that language. After the new language add-in has been installed, it will replace the original language version of the add-in. All copies of the Remove Hidden Data add-in, in any language, include an English-language version to support the command-line tool.

This tool cannot remove hidden data from the following types of files:
  • Documents using rights-management permissions
  • Protected documents
  • Digitally signed documents
  • Shared workbooks
If you try to run this tool on a file that meets one or more of these conditions, the tool will terminate operation and display an error message. The original file is unchanged.

System requirements

Supported Operating Systems: Microsoft Windows XP SP1 or later, Microsoft Windows 2000 SP4 or later, or Microsoft Windows Server 2003

This download works with the following Office applications:
  • Microsoft Office Word 2003
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Word 2002, SP2 or later
  • Microsoft Excel 2002, SP2 or later
  • Microsoft PowerPoint 2002, SP2 or later
You must have the application in which the document was created installed to run the add-in. Also, the version of Office that you have must be the same or newer than the version of the document on which you want to run the Remove Hidden Data tool. For example, you can run the tool on an Office 2000 document using Office 2003, but you cannot run the tool on an Office 2003 document using Office XP.

Remove Hidden Data works with Word documents, Excel spreadsheets, and PowerPoint presentations, as well as Web pages and single-file Web pages; created by Word, Excel and PowerPoint. It does not work with other document formats.

Types of data this add-in can remove

The following types of data are removed automatically.
  • Comments.
  • Previous authors and editors.
  • User name.
  • Personal summary information.
  • Revision marks. The tool accepts all revisions specified in the document. As a result, the contents of the document will correspond to the Final Showing Markup view on the Reviewing toolbar.
  • Deleted text. This data is removed automatically.
  • Versions.
  • VB Macros. Descriptions and comments are removed from the modules.
  • The ID number used to identify your document for the purpose of merging changes back into the original document.
  • Routing slips.
  • E-mail headers.
  • Scenario comments.
  • Unique identifiers (Office 97 documents only).
Note The Remove Hidden Data tool also turns on the Remove Personal Information feature. For more information on this feature, please search for "Remove Personal Information" in the application Help.

Known issues

  • Excel: In Excel 2002, printer paths are not removed; however, they are removed in Excel 2003.
  • Excel: The link to a supporting external workbook may not be cleaned from an Excel single-file Web page.
  • If the Remove Hidden Data add-in shuts down unexpectedly, an empty Notepad window may appear and a log file may be left in your temporary directory. To close the Notepad window, press File, Exit in Notepad. To remove this log file, delete the contents of the temporary directory in your local settings folder.
  • If you close the Remove Hidden Data add-in before it is finished reviewing a document, one or more temporary files may be left in the destination directory. To remove these files, delete them from the destination directory.
  • Single-file Web pages that have been reviewed by this tool may contain the name of a randomly generated temporary file in the form file:///c:/<number>/. The number used in this name is based on the file name of the single-file web page and cannot be traced back to your computer.
  • Existing hidden random numbers, used to improve merge accuracy and stored in Word files, are not removed.
  • When run from the command line, the Remove Hidden Data add-in does not work on XML documents created in Word, Excel, or PowerPoint.

Basic use

After you install the Remove Hidden Data add-in, open the document you want to review, then, on the File menu, click Remove Hidden Data.

Note If you do not see the Remove Hidden Data command on the File menu, check the following:
  1. On the Tools menu, click Options, and then click the Security tab.
  2. Under Macro Security, click Macro Security.
  3. Click the Trusted Publishers tab.
  4. Select the Trust all installed add-ins and templates check box, and then click OK twice.
After you specify the file name, the tool will remove specified hidden data automatically. See Types of data this add-in can remove for more information.

Notes

You should always save to a new file name, rather than overwrite the original file with the new document, in order to preserve a copy of the document containing the original data.

The Remove Hidden Data add-in does not support saving documents as templates.

Command line

To run the Remove Hidden Data add-in from the command-line, do the following:
  1. Quit all instances of Excel, Word, Outlook, and PowerPoint before launching the command-line tool.
  2. On the Start menu, click Run.
  3. Type cmd, and then press ENTER.
  4. Switch to the directory that contains the OFFRHD.EXE file. By default, this is the directory where you installed the Remove Hidden Data add-in.
  5. At the command prompt, type the syntax for the task you want to perform.
Notes

Although your document application is not visible, it is running in the background. If the application launches a dialog box, the Remove Hidden Data add-in will pause until the dialog box is closed. If the dialog box remains open more than 120 seconds, the application will terminate and the Remove Hidden Data add-in will proceed to the next file, or close if it has reached the last file.

You can type either a slash (/) or a dash (-) as a flag to precede parameters. Flags are not case-sensitive.

If you type in multiple flags, only the first one will be recognized.

You must enter the /source parameter first, optionally followed by the /destination parameter. All other parameters can be in any order.

If you type a slash (/) at the end of the source directory name, the tool will fail.

The syntax for OFFRHD.EXE is as follows:
OFFRHD [/?] source [destination] [/O] [/R] [/F:filetype] [/L: logfile] [/A]
Collapse this tableExpand this table
ParameterDescription
sourceRequired. Specifies the drive, directory, and files for which you want to remove personal information. Can be any valid, fully-qualified path name.
destinationOptional. Specifies a location for scanned files. If you do not specify this field, all files will be saved in the same directory with a suffix representing the current date. For example, -C010503 would represent January 5, 2003. If the destination file already exists, it will be overwritten.
/OSpecifies that no prompt will display to confirm that you want to overwrite an existing file.
/RSpecifies that contents of the source directory and its subdirectories will be examined.
/F:filetypeSpecify format for destination files.
/F:HSpecifies HTML.
/F:MSpecifies MHTML.
/F:BSpecifies binary document format. If you do not specify this parameter, the default will be to save in the same format as the source file.
/L:logfileSpecifies a location to stores the log file. If you do not specify this, the log will display when the tool is finished.
/ASpecifies that the tool will generate a report of issues found in the file but will not remove any data.
/:?Displays a list of all available parameters.

Log file

When the Remove Hidden Data add-in is finished reviewing the file(s), a log file displays the results of the review process. You can save this file if you want to refer to it later.


APPLIES TO
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002
Keywords: 
kbcommandline kbconfig kbtooltip kbinfo KB834427
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support