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Article ID: 835261 - Last Review: May 18, 2007 - Revision: 2.6

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SYMPTOMS

After you reconnect to a network, you may not be able to open a domain-based Distributed File System (DFS) link or a domain-based DFS root for up to 15 minutes. Therefore, you may experience problems when your computer first tries to synchronize offline files to a DFS root or to a DFS link.

CAUSE

Microsoft Windows XP-based DFS clients that belong to a domain periodically query the domain controllers to distinguish queries for fully qualified domain names (FQDNs) from queries for fully qualified computer names. The results of the discovery process are cached in a special table that is named the "SPC cache." The client uses the SPC cache to avoid real-time queries to domain controllers in the domain. If the Windows XP-based client cannot populate the SPC cache when the computer first starts, the client will try again after one minute for three more times. After the third try, or after three minutes, the client will wait 15 minutes before it tries to populate the SPC cache again. Therefore, if the DFS server is unavailable at first, the Windows XP-based client may have to wait for up to 15 minutes before the client can connect to the domain-based DFS namespace.

Therefore, the Windows XP-based client cannot synchronize offline files to a DFS root or a DFS link until the client can access the DFS namespace.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Feb-2004  00:21  5.1.2600.1334      92,160  Cscdll.dll       
   10-Feb-2004  19:22  5.1.2600.1342     416,640  Mrxsmb.sys
   13-Feb-2004  00:21  5.1.2600.1335     305,152  Netapi32.dll     
   10-Feb-2004  19:22  5.1.2600.1334     165,760  Rdbss.sys
   13-Feb-2004  00:21  5.1.2600.1335     120,320  Wkssvc.dll       

Note You must enable Offline Files support to use this hotfix.After you apply this hotfix, the Windows XP-based client populates the SPC cache if it is empty and if one of the following conditions occurs:
  • Offline files are synchronized.
  • A new network connection is detected.

With this hotfix, you can access the domain-based DFS namespace faster than was previously possible.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about how to control the frequency of Windows XP-based client DFS queries, click the following article number to view the article in the Microsoft Knowledge Base:
291377  (http://support.microsoft.com/kb/291377/ ) Policy to control the frequency of Windows XP client DFS queries
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
834674  (http://support.microsoft.com/kb/834674/ ) Domain DFS network path goes offline after you open Windows Explorer or My Computer in Windows XP


For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbtshoot kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB835261
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