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Article ID: 842520 - Last Review: August 29, 2007 - Revision: 3.1

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SYMPTOMS

After you save a file to media, such as Compact Flash, Memory Stick, SmartMedia, or Secure Digital memory devices, on a Microsoft Windows XP-based computer, you may receive the following error message:
Delayed Write Failed
The message may not appear immediately after you save the file, and the file may not be saved.

CAUSE

This problem may occur if all the following conditions are true:
  • You save the file to an Advanced Technology Attachment (ATA) media device that is write-protected or read-only.
  • Your computer is using a CardBus controller that does not support the Removable Device Notifications feature set.
This problem is known to occur with certain Texas Instruments CardBus controllers.

The following CardBus controller chipsets are known to be affected by this issue:
  • Texas Instruments PCI1620
  • Texas Instruments PCI7410
  • Texas Instruments PCI7610

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name   SP level
   -------------------------------------------------------------------
   09-Aug-2004  21:17  5.1.2600.1581      89,600  Atapi.sys   SP1QFE       
   09-Aug-2004  22:40  5.1.2600.2505      95,616  Atapi.sys   SP2QFE      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates


The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kberrmsg kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug kbqfe kbhotfixserver KB842520
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