DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 842827 - Last Review: October 9, 2011 - Revision: 2.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

SYMPTOMS

When you log off from a Microsoft Windows XP-based computer, the system may not unload your user profile correctly. Additionally, the following error may be logged in the Application log:

Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1524
Description:
Windows cannot unload your classes registry file - it is still in use by other applications or services. The file will be unloaded when it is no longer in use.

When you log on to the computer again, the HKEY_CURRENT_USER\Software\Classes registry subkey is not loaded. Additionally, certain COM operations fail. For example, the COM operations for Outlook Forms fails.

CAUSE

This problem occurs because, when you log on to the computer, the WebDav client service caches a handle to the HKEY_CURRENT_USER\Software\Classes registry subkey during per-user initialization.

The HKEY_CURRENT_USER\Software\Classes registry subkey is the Usrclass.dat file in your user profile. The HKEY_CURRENT_USER\Software\Classes registry subkey is used for per-user COM registrations. Therefore, the HKEY_CURRENT_USER\Software\Classes registry subkey cannot be unloaded when you log off from the computer because of the cached handle.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows XP SP2 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.1.2600.3039617,47222-Nov-200613:07x86SP2SP2QFE
Webclnt.dll5.1.2600.303968,09622-Nov-200613:07x86SP2SP2QFE

WORKAROUND

To work around this problem, use the Microsoft User Profile Hive Cleanup Service (UPHClean). UPHClean monitors the computer while Windows is unloading user profiles. UPHClean forces resources that are open to close. Therefore, the computer can unload the user profiles.

To download and install UPHClean, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582 (http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The HKEY_CLASSES_ROOT registry subtree is the merged view of the HKEY_CURRENT_USER\Software\Classes registry subkey and the HKEY_LOCAL_MACHINE\Software\Classes registry subkey. When the system reads from the HKEY_CLASSES_ROOT registry subtree, the per-user data that is located under the HKEY_CURRENT_USER registry subtree overrides the per-computer data that is located under the HKEY_LOCAL_MACHINE registry subtree. If the system writes to the HKEY_CLASSES_ROOT registry subtree, the data is redirected to the HKEY_CURRENT_USER\Software\Classes registry subkey. The HKEY_CURRENT_USER\Software\Classes registry subkey is the Usrclass.dat file in the user’s profile. Therefore, users can create their own COM class registrations because regular users typically have read-only access to the HKEY_LOCAL_MACHINE\Software\Classes registry subkey.

When the problem that is described in this article occurs, the HKEY_CURRENT_USER\Software\Classes registry subkey does not appear in the registry the next time that the user logs on to the computer. Therefore, the per-user COM registrations are missing.

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbtshoot kbexpertiseinter kbprb KB842827
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support