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Article ID: 843170 - Last Review: October 26, 2013 - Revision: 2.0

This article has been archived. It is offered "as is" and will no longer be updated.

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Symptoms

When you perform a knowledge base search by using the Microsoft Business Solutions CRM 1.2 Knowledge Base Manager, you receive the following HTTP 404 error message:
The page cannot be found.

Cause

In the Home_managekb.aspx page in Microsoft CRM 1.2, an incorrect setting in line 51 causes this problem. Line 51 incorrectly sets the crmGrid.document.location setting to the following variable that is undefined:
_sGridQueueUrl

Workaround

To work around this problem, follow these steps:
  1. In the Microsoft CRM Web client, click GoTo, point to Service, and then click KB Manager.
  2. Click Draft on the Article Queues tab.
  3. Click the Search tab.
  4. Type the words that you want to search for in the Search For box, and then click Search.
  5. Click the Article Queues tab, and then click Published.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem is scheduled to be fixed in Microsoft Business Solutions CRM 2.0.

More information

Steps to reproduce the problem

  1. In the Microsoft CRM Web client, click GoTo, point to Service, and then click KB Manager.
  2. Click the Search tab.
  3. Type the words that you want to search for in the Search For box, and then click Search.
  4. Click the Article Queues tab, and then click Published.

Applies to
  • Microsoft Business Solutions CRM Customer Service, when used with:
    • Microsoft CRM 1.2
Keywords: 
kbnosurvey kbarchive kbmbsmigrate kbbug KB843170
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