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Article ID: 885855 - Last Review: June 20, 2014 - Revision: 5.0

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Symptoms

If you run the Out-of-Box Experience (OOBE) and then restart your Microsoft Windows XP Service Pack 2 (SP2)-based computer, infrared communications may no longer work. You cannot use the infrared port to transfer data. If you delete the infrared device and then restart the computer, infrared communications work. However, if you restart the computer again, infrared communications no longer work.

Note When this problem occurs, you can still use infrared communications to print. Infrared printing is not affected by this problem.

Cause

This problem occurs because of a race condition that occurs at startup between the Irmon service and the Winlogon service. This problem is known to occur with certain portable computers.

Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Sep-2004  17:49  5.1.2600.2524      27,136  Irmon.dll     

Workaround

To work around this problem, follow these steps to stop and restart the Irmon service:
  1. Click Start, point to All Programs, point to Administrative Tools, and then click Services.
  2. In the details pane, right-click Irmon, and then click Stop.
  3. After the Irmon service stops, right-click Irmon again, and then click Start.
  4. Quit Services.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
Keywords: 
kbautohotfix kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug kbqfe kbhotfixserver KB885855
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