DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 889334 - Last Review: June 20, 2014 - Revision: 4.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

Symptoms

When you try to upload a file to a secure Web site in Microsoft Internet Explorer 6, the file upload may time out or may take longer than expected to finish.

Cause

This problem may occur when all the following conditions are true:
  • You have installed Microsoft Windows XP Service Pack 2 (SP2).
  • The Web page to which you upload the file uses a Secure Sockets Layer (SSL) connection.
  • The URL to connect to the secure Web site starts with https://.
  • The Web page to which you upload the file is one of the following:
    • An active server page (.asp).
    • A Web page that uses a script to process the uploaded file.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows XP SP2 installed to install this hotfix.

For additional information about how to obtain Windows XP Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack

Restart requirement

You may have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

After you install this hotfix, follow these steps to enable the hotfix.Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
  1. Quit Internet Explorer 6.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BUFFERBREAKING_818408
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type Iexplore.exe, and then press ENTER.
  6. Right-click Iexplore.exe, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Select the key that is specified in step 3.
  9. On the Edit menu, point to New, and then click Key.
  10. Type Settings, and then press ENTER.
  11. With the Settings key selected, on the Edit menu, point to New, and then click DWORD Value.
  12. Type BufferBreakingSize, and then press ENTER.
  13. Right-click BufferBreakingSize, and then click Modify.
  14. In the Value data box, type 00a00000, and then click OK.

    Notes
    • The default value for BufferBreakingSize is 8,000 bytes.
    • Using the recommended Value data value of 00a00000 changes BufferBreakingSize to 10 megabytes (MB).
    • Do not exceed a BufferBreakingSize of 30 MB (Value data = 01e00000).
  15. Quit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size      File name
   --------------------------------------------------------
   16-Dec-2004  18:38  6.0.2900.2577  656,896   Wininet.dll

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

The hotfix that is described in this article is included in Microsoft Security Update MS05-014.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
Keywords: 
kbautohotfix kbwinxppresp3fix kbqfe kbfix kbbug kbhotfixserver KB889334
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support