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Article ID: 891019 - Last Review: June 20, 2014 - Revision: 4.0

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For a Microsoft Windows XP Service Pack 1 version of this article, see 895394  (http://support.microsoft.com/kb/895394/ ) .

Symptoms

In Microsoft Windows XP with Service Pack 2 (SP2), images may appear as blank boxes when you view a Web archive (.mht) file.

Cause

This problem occurs because the CreateMHTMLBody method does not correctly format spaces in a URL. The problem occurs when a URL in the .mht file contains the %20 character. Blank spaces in this URL are replaced with the %20 blank space code.

The CreateMHTMLBody method is included in the Microsoft Collaboration Data Objects for Windows (CDOSYS) library.

Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Windows XP Service Pack 2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size  File name
   -----------------------------------------------------
   28-Feb-2005  02:34  6.2.3.0   2,068,480  Cdosys.dll
   24-Feb-2005  20:24  6.1.22.4    371,936  Updspapi.dll

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug KB891019
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