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Article ID: 894685 - Last Review: August 29, 2007 - Revision: 3.2

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SYMPTOMS

In Microsoft Windows XP, removable devices may not appear when you use the Forgotten Password Wizard or the Password Reset Wizard. For example, when you use the Forgotten Password Wizard to create a password reset disk, removable devices may not appear in the list of devices to which you can back up your password. Additionally, when you use the Password Reset Wizard to reset your password, removable devices may not appear in the list of devices from which you can restore your password.

CAUSE

This problem occurs if all the following conditions are true:
  • More than one removable disk drive is connected to the computer.
  • The removable disk drive that you want to select was not connected when you turned on the computer.
  • You do not use the Windows XP Welcome screen to log on the computer. For example, you press CTRL+ALT+DELETE to log on the computer.
  • You press CTRL+ALT+DELETE to start the Forgotten Password Wizard, or you try to log on to the computer and then start the Password Reset Wizard.
This problem occurs because the Windows Shell Common DLL component (Shell32.dll) stops disk drive information from correctly displaying the first time that information is requested. This information is required for the disk drive to display on the Windows desktop.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Windows XP Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack
Note We recommend that you also apply the hotfix that is mentioned in the following Knowledge Base article:
894686  (http://support.microsoft.com/kb/894686/ ) The Forgotten Password Wizard incorrectly backs up your password to the C drive, or you receive a "This disk is not a password reset disk" error message when you try to use the Password Reset Wizard to reset your password in Windows XP

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   01-Sep-2005  01:44  6.0.2900.2751  8,452,608  Shell32.dll

WORKAROUND

You may be able to work around this problem by using one of the following methods:

Method 1: Restart the computer

Restart the computer with the removable disk drives connected. Then, try to back up or restore your password.

Method 2: Restart the Forgotten Password Wizard or the Password Reset Wizard

Quit and then restart the Forgotten Password Wizard or the Password Reset Wizard. One or more of the removable disk drives may then appear in the wizard.

Note You may have to restart the wizard one time for each removable disk drive that is connected.

Method 3: Start the Forgotten Password Wizard from Control Panel

Do not press CTRL+ALT+DELETE to start the Forgotten Password Wizard. Instead, use the User Accounts Control Panel item to start the wizard. To do this, follow these steps:
  1. Click Start, click Run, type control userpasswords, and then click OK.
  2. Click the account whose password you want to change, and then click Prevent a forgotten password.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
306214  (http://support.microsoft.com/kb/306214/ ) How to create and use a password reset disk for a computer in a domain in Windows XP
305478  (http://support.microsoft.com/kb/305478/ ) How to create and use a password reset disk for a computer that is not a domain member in Windows XP

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB894685
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