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Article ID: 895115 - Last Review: October 9, 2011 - Revision: 3.0

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SYMPTOMS

After you enable offline files, Windows Explorer does not display icons for the following files:
  • .msg files
  • .htm files
  • .html files
This problem occurs if the following conditions are true:
  • The computer uses the NTFS file system.
  • You have installed hotfix 839645 (Microsoft security bulletin MS04-024) on a computer that is running Microsoft Windows XP with Service Pack 1. Or, the computer is running Windows XP with Service Pack 2 or Windows Server 2003.

CAUSE

This problem occurs because these file types have their own icon handlers.

RESOLUTION

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, one of the following conditions must be true:
  • You have installed Windows XP Service Pack 1 and security bulletin MS04-024 or a later security bulletin.
  • You have installed Windows XP Service Pack 2.

Restart requirement

You must restart the computer after you apply this hotfix. This will load the Shell32.dll file.

Hotfix replacement information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.2900.27038,452,09621-Jun-200506:11x86SP2SP2QFE
Shlwapi.dll6.0.2900.2703473,60021-Jun-200506:11x86SP2SP2QFE
Xpsp3res.dll5.1.2600.270317,92021-Jun-200501:47x86SP2SP2QFE

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix. This will load the Shell32.dll file.

Hotfix replacement information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.30618,385,53619-Dec-200708:11x86SP1SP1QFE
W03a2409.dll5.2.3790.306128,67218-Dec-200710:32x86SP1SP1QFE
Shell32.dll6.0.3790.42078,360,96019-Dec-200707:52x86SP2SP2QFE


Windows Server 2003, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.306110,504,70419-Dec-200706:55x64SP1SP1QFE
W03a2409.dll5.2.3790.306129,18419-Dec-200706:55x64SP1SP1QFE
Wshell32.dll6.0.3790.30618,385,53619-Dec-200706:55x86SP1WOW
Ww03a2409.dll5.2.3790.306128,67219-Dec-200706:55x86SP1WOW
Shell32.dll6.0.3790.420710,508,28819-Dec-200707:01x64SP2SP2QFE
Wshell32.dll6.0.3790.42078,360,96019-Dec-200707:01x86SP2WOW


Windows Server 2003, IA64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.306113,241,85619-Dec-200707:00IA-64SP1SP1QFE
W03a2409.dll5.2.3790.306127,64819-Dec-200707:00IA-64SP1SP1QFE
Wshell32.dll6.0.3790.30618,385,53619-Dec-200707:00x86SP1WOW
Ww03a2409.dll5.2.3790.306128,67219-Dec-200707:00x86SP1WOW
Shell32.dll6.0.3790.420713,244,92819-Dec-200707:00IA-64SP2SP2QFE
Wshell32.dll6.0.3790.42078,360,96019-Dec-200707:01x86SP2WOW

WORKAROUND

To work around this problem, move the affected files to a different disk. Then, move them back to the original folder.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To enable offline files, click to select the Enable Offline Files check box on the Offline Files tab of the Folder Options dialog box.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbautohotfix kbfix kbhotfixserver kbqfe KB895115
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