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Article ID: 897242 - Last Review: October 9, 2011 - Revision: 4.0

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Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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SYMPTOMS

If you try to use Microsoft Internet Explorer 6 or Internet Explorer 6 Service Pack 1 (SP1) to open an image file, the image file does not appear in Internet Explorer. Instead, a blank box appears in Internet Explorer. However, you can use the Windows Picture Viewer program to open and to view the image file.

CAUSE

This problem occurs if the following conditions are true:
  • The image file is encoded by using Portable Network Graphics (PNG) encoding.
  • That PNG file contains one or more zero-length IDAT chunks.

RESOLUTION

Security update information

To resolve this problem, install the most current cumulative security update for Internet Explorer. To install the most current updates, visit the following Microsoft Web site:
http://update.microsoft.com (http://update.microsoft.com)
For more technical information about the most current cumulative security update for Internet Explorer, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/current.aspx (http://www.microsoft.com/technet/security/current.aspx)
Note This fix was first included in security update 947864 (MS08-024). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
947864  (http://support.microsoft.com/kb/947864/ ) MS08-024: Cumulative Security Update for Internet Explorer


Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Internet Explorer 6 or Internet Explorer 6 SP1 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
--------------------------------------------------------------
20-Apr-2005  21:11   6.0.2800.1504     38,912   Pngfilt.dll

Hotfix installation instructions

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.After you apply this hotfix, follow these steps to add the new FEATURE_IGNORE_EMPTY_IDAT_CHUNKS_KB897242 subkey to the registry:
  1. Click Start, click Run, type regedit, and then click OK.
  2. In the left pane, expand HKEY_LOCAL_MACHINE, expand SOFTWARE, expand Microsoft, expand Internet Explorer, expand Main, and then expand FeatureControl.
  3. In the Edit menu, point to New, and then click Key.
  4. Type FEATURE_IGNORE_EMPTY_IDAT_CHUNKS_KB897242 to name the new key.
  5. Click FEATURE_IGNORE_EMPTY_IDAT_CHUNKS_KB897242, point to New in the Edit menu, and then click DWORD Value.
  6. Type iexplore.exe to name the new value.
  7. Right-click iexplore.exe, and then click Modify.
  8. In the Value data box, type 1, and then click OK.
  9. Point to New in the Edit menu, and then click DWORD Value.
  10. Type explorer.exe to name the new value.
  11. Right-click explorer.exe, and then click Modify.
  12. In the Value data box, type 1, and then click OK.
  13. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in Internet Explorer 6.

MORE INFORMATION

The PNG specification allows for the use of a zero-byte IDAT chunk. For more information about the PNG specification, see RFC 2083 at the following Web site:
http://www.faqs.org/rfcs/rfc2083.html (http://www.faqs.org/rfcs/rfc2083.html)
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

APPLIES TO
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
    • Microsoft Windows XP Tablet PC Edition
Keywords: 
kbautohotfix kbqfe kbHotfixServer kbie600sp2fix kbie600presp2fix kbfix kbbug KB897242
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