DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 900910 - Last Review: June 20, 2014 - Revision: 2.0

On This Page

Symptoms

When you try to run the System File Checker tool (Sfc.exe) on a Microsoft Windows XP Service Pack 2 (SP2)-based computer, you may be prompted to insert the Windows XP SP2 CD. However, the System File Checker does not accept either the Windows XP SP2 CD or the original Windows XP CD.

Note You can install Windows XP SP2 either from the Windows XP SP2 CD or by downloading the SP2 files. To download the SP2 files, visit the following Microsoft Web site:
http://support.microsoft.com/windowsxpsp2 (http://support.microsoft.com/windowsxpsp2)

Cause

This problem occurs because the System File Checker must verify the SP2 files against the originally installed files. However, the System File Checker does not recognize the Windows XP SP2 CD or the Windows XP CD.

Resolution

To resolve the problem, use one of the following methods.

Method 1: Insert a Windows XP CD that has SP2 integrated

For more information about how to integrate software updates into Windows installation source files, click the following article number to view the article in the Microsoft Knowledge Base:
828930  (http://support.microsoft.com/kb/828930/ ) How to integrate software updates into your Windows installation source files

Method 2: Modify the registry to point to the Windows XP SP2 Setup files

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
  3. In the right pane, right-click ServicePackSourcePath, click Modify, type %windir%\ServicePackFiles, and then click OK.

More information

Steps to reproduce the problem

  1. Install Windows XP or Windows XP Service Pack 1 (SP1).
  2. Install Windows XP SP2.
  3. Click Start, click Run, type cmd in the Open box, and then click OK.
  4. At the command prompt, type sfc /scannow, and then press ENTER. You are prompted to insert the Windows XP SP2 CD.
  5. Insert the Windows XP SP2 CD or the Windows XP CD.
You experience the problem that is described in the "Symptoms" section.

References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
897128  (http://support.microsoft.com/kb/897128/ ) You may be prompted to insert a Windows XP Professional CD when you run the System File Checker tool in Windows XP Home Edition
885522  (http://support.microsoft.com/kb/885522/ ) System File Checker does not accept a network location that contains the installer CD when you use the scannow switch in Windows XP SP2 or in Windows Server 2003
Keywords: 
kbtshoot kbprb KB900910
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support