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Article ID: 903936 - Last Review: June 12, 2009 - Revision: 3.0

SYMPTOMS

You cannot use the System Preparation tool (Sysprep.exe) to create an image of a computer that is running Microsoft Windows Embedded for Point of Service (WEPOS).

You may receive an error message that resembles the following:
The system is not fully installed. Please run setup again

CAUSE

This issue occurs because files that are required to run Sysprep.exe are missing.

RESOLUTION

To resolve this issue for WEPOS without Service Pack 3, follow these steps:
  1. Download the WePOS-KB903936.exe executable package. To obtain this software update, visit the following Microsoft Web site:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=382E67CE-EBFD-43CC-AD83-B7953D49B5F4 (http://www.microsoft.com/downloads/details.aspx?FamilyId=382E67CE-EBFD-43CC-AD83-B7953D49B5F4)
  2. Copy the WePOS-KB903936.exe file to the destination computer, and then double-click the file to extract the software update.
  3. After you apply the software update, add the following information to the [Unattended] section of each Sysprep.inf file that you create.
    InstallFilesPath=c:\windows\fonts
    InstallFilesPath=c:\windows\system32
    Note If you do not add this information to the [Unattended] section of each Sysprep.inf file that you create, you may receive two error messages that resemble the following message:
    File Not Found
    You receive these error messages when you run Mini-Setup or the Microsoft Out of Box Experience. When you receive these error messages, the missing files are located in the file paths that are mentioned earlier in this section.

    Note To run Mini-Setup or the Microsoft Out of Box Experience without error, you must install the following optional components when you install WEPOS:
    • Additional Driver Support
    • Local Management Tools
    • Management Client Support
    • Additional Fonts
    • Additional CodePage Support
    • Additional Input Devices
    Additionally, copy an empty file named 8514oemr.fon to the %SystemRoot%\Font directory. (An empty text file that is created in Notepad will work.)
To resolve this issue for WEPOS with Service Pack 3 for WEPOS installed, follow these steps:
  1. To run Mini-Setup or the Microsoft Out of Box Experience without error, you must install the following optional components when you initially install WEPOS:
    • Additional Driver Support
    • Local Management Tools
    • Management Client Support
    • Additional Fonts
    • Additional CodePage Support
    • Additional input devices
  2. Install this update:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=382E67CE-EBFD-43CC-AD83-B7953D49B5F4 (http://www.microsoft.com/downloads/details.aspx?FamilyId=382E67CE-EBFD-43CC-AD83-B7953D49B5F4)
    Note This update must be installed before SP3 is installed.
  3. Install any other WEPOS-specific updates that required for the system. (These updates must be installed before SP3 is installed.)
  4. Install the Service Pack 3 update for Windows Embedded for Point of Service.
  5. Install the latest post-SP3 security updates.
  6. Install all required drivers.
  7. Create a file named 8514oemr.fon and place it in the %SystemRoot%\Font directory. (An empty text file that is created in Notepad will work.)
  8. If kbdbhc.dll does not already exist, create a file named kbdbhc.dll and place it in the %SystemRoot%\System32 directory. (An empty text file that is created in Notepad will work.)
  9. In addition to applying the KB903936 software update, you must add the following information to the [Unattended] section of each Sysprep.inf file that you create:
    InstallFilesPath=c:\windows\fonts
    InstallFilesPath=c:\windows\system32

    Note If you do not add this information to the [Unattended] section of each Sysprep.inf file that you create, you may receive two error messages that resemble the following message: "File Not Found" when you run Mini-Setup or the Microsoft Out of Box Experience.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Embedded Point of Service
  • Service Pack 3 for Windows Embedded for Point of Service and Windows Fundamentals for Legacy PCs
Keywords: 
kbprb kbbug kbfix kbqfe kbpubtypekc KB903936
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