DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 908356 - Last Review: October 26, 2007 - Revision: 1.3

SYMPTOMS

If Microsoft Internet Explorer is configured to use a proxy auto-configuration (.pac) file, when you browse a secure Web site that contains multiple frames you may receive one of the following scripting error messages:

Message 1
Access Denied
Message 2
Permission Denied

CAUSE

This issue occurs because Internet Explorer does not correctly evaluate Internet security zones before it finishes processing the .pac file. When this occurs, Internet Explorer may assign a URL to an unexpected zone.

WORKAROUND

To work around this issue, add the Web site that is affected to the Trusted sites security zone in Internet Explorer. To do this, follow these steps:
  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. On the Security tab, click Trusted sites, and then click Sites.
  4. In the Add this Web site to the zone box, type the URL of the Web site that is affected, and then click Add.
  5. Click OK.
Note You can also configure Internet Explorer settings by using Group Policy. For more information about how to do this, visit the following Microsoft Web site:
Managing Windows XP Service Pack 2 Features Using Group Policy
http://technet.microsoft.com/en-us/library/bb457144.aspx (http://technet.microsoft.com/en-us/library/bb457144.aspx)

MORE INFORMATION

You can configure Internet Explorer to use a .pac file to specify the proxy server that must be used to access a URL. Just as Internet Explorer uses the proxy exception list, Internet Explorer uses the .pac file to determine the zone for a URL. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
884430  (http://support.microsoft.com/kb/884430/ ) Your home page is assigned to the incorrect security zone if Internet Explorer uses a proxy auto-configuration (.pac) file to specify proxy settings

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition
Keywords: 
kberrmsg kbtshoot kbprb KB908356
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support