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Article ID: 912154 - Last Review: October 9, 2011 - Revision: 5.0

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SYMPTOMS

When you try to create a diagnostic report for DFS replication on a Microsoft Windows Server 2003 R2-based computer, the operation is unsuccessful. Additionally, you receive the following error message:
The Diagnostic Report Wizard could not be completed. Refer to the Errors tab for the specific warning.
The following information appears on the Errors tab:
ReplicationGroupName: The health report cannot be generated. Error HRESULT E_FAIL has been returned from a call to a COM component
Note In this message, ReplicationGroupName is the name of the replication group against which you were running a health report.

You experience this problem when the system date is in the month of December on the following systems:
  • The server that you use to create the report
  • The servers that you include in the diagnostic report

CAUSE

This problem occurs because of an "off-by-one" error in the custom date formatting functionality in Windows Server 2003 R2.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Download information

The following files are available for download from the Microsoft Download Center:

Windows Server 2003

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Windows Server 2003, x64-based versions

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Download the 912154 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=F643E660-784E-4FAE-9950-BDC60E5C5BD9)

Release Date: March 2006

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Dfsrhelper.dll5.2.3790.2590253,44010-Dec-200503:22x86
Windows Server 2003 R2, x64-based versions
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File nameFile versionFile sizeDateTimePlatform
Dfsrhelper.dll5.2.3790.2590870,91209-Dec-200514:00IA-64
Windows Server 2003 R2, Itanium-based versions
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File nameFile versionFile sizeDateTimePlatform
Dfsrhelper.dll5.2.3790.2590498,68809-Dec-200513:58x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

For more information about the description of the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
For more information about how to create a diagnostic report for DFS replication, visit the following Microsoft Web site:
http://technet2.microsoft.com/WindowsServer/en/Library/55c95a18-0a8c-420d-85a0-f10913d27fcc1033.mspx (http://technet2.microsoft.com/WindowsServer/en/Library/55c95a18-0a8c-420d-85a0-f10913d27fcc1033.mspx)

APPLIES TO
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
Keywords: 
kbhotfixserver kbautohotfix atdownload kbwinserv2003sp2fix kbbug kbfix kbqfe KB912154
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