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Article ID: 912572 - Last Review: October 11, 2007 - Revision: 3.3

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SYMPTOMS

After you create an application to access an Authorization Manager (Azman) store in Windows Server 2003 with Service Pack 1 (SP1) or in Microsoft Windows XP with Service Pack 2 (SP2), you receive the following error message:
Unable to cast COM object of type 'System.__ComObject' to interface type 'Microsoft.Interop.Security.AzRoles.IAzApplication'. This operation failed because the QueryInterface call on the COM component for the interface with IID <GUID> failed with HRESULT: 0x80004002 (No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE))).
This problem occurs if the following conditions are true:
  • You used the Component Object Model (COM) interface to create the application.
  • The Azman store is created in a Multiple-Thread Apartment (MTA) thread.
  • A Single-Thread Apartment (STA) thread tries to access the Azman store.

CAUSE

This problem occurs because, when the Azman store is in an MTA thread, the store cannot be accessed by a STA thread.

RESOLUTION

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites
Windows Server 2003 SP1 must be installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Azroles.dll5.2.3790.2607232,96004-Jan-200603:38x86
Updspapi.dll6.2.29.0371,42412-Oct-200523:13x86
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.2607705,53603-Jan-200612:30IA-64SP1SP1QFE
Wazroles.dll5.2.3790.2607232,96003-Jan-200612:30x86SP1WOW
Updspapi.dll6.2.29.0638,68803-Jan-200612:31IA-64NoneNot Applicable
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.2607416,25603-Jan-200612:29x64SP1SP1QFE
Wazroles.dll5.2.3790.2607232,96003-Jan-200612:29x86SP1WOW
Updspapi.dll6.2.29.0462,04803-Jan-200612:31x64NoneNot Applicable

Windows XP

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
Windows XP SP2 must be installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Azroles.dll5.2.3790.2729233,47218-Aug-200614:18x86
Updspapi.dll6.2.29.0371,42412-Oct-200523:12x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

APPLIES TO
  • Microsoft Windows Server 2003 Service Pack 1, when used with:
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbexpertiseinter kbhotfixserver kbqfe KB912572
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