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Article ID: 918310 - Last Review: August 29, 2007 - Revision: 2.1

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SYMPTOMS

When you search for content in a Web page by using the Find command on the Edit menu in Microsoft Internet Explorer 6, CPU utilization increases to 100 percent on a Microsoft Windows XP-based computer. Additionally, other programs may slow down or become unresponsive.

This problem also occurs if you call the IHTMLTxtRange::findText method to search for content programmatically. Typically, you experience this behavior when the Web page contains hundreds of paragraph (<P>) tags.

CAUSE

This problem occurs because of a problem in the IHTMLTxtRange::findText method.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on the computer.

Restart information

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previous hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll6.0.2900.29923,058,68808-Sep-200612:53x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Professional Service Pack 2 (SP2)
    • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
Keywords: 
kbautohotfix kbexpertiseinter kbhotfixserver kbwinxpsp3fix kbqfe kbprb KB918310
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