DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 918334 - Last Review: October 9, 2011 - Revision: 3.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

SYMPTOMS

Consider the following scenario. You run a Win32 program that uses the Server Message Block (SMB) protocol to make function calls from a Microsoft Windows XP-based client computer to a server. The program uses the CreateFile function to open a file on the server. In this scenario, when the program tries to open the same file again, you may receive the following error message on the client computer:
System error 32. The process cannot access the file because it is being used by another process.
A Network Monitor trace shows the following error message:
System Error, Code= (67) STATUS_SHARING_VIOLATION

CAUSE

This problem occurs when the Windows redirector uses dynamic reauthentication for the Kerberos protocol. If the Kerberos session ticket expires and is automatically renewed after the first call to the CreateFile function, the redirector does not send a command to the server to close the file. Because the file remains open on the server, you receive the error message that is mentioned in the "Symptoms" section.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must be running Windows XP Service Pack 1 or Windows XP Service Pack 2 to apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cscdll.dll5.1.2600.159992,16028-Oct-200401:29x86
Mrxsmb.sys5.1.2600.1856433,15215-Jun-200608:43x86
Rdbss.sys5.1.2600.1856166,65615-Jun-200608:52x86
Windows XP Service Pack 2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.1.2600.2930454,40015-Jun-200609:28x86
Rdbss.sys5.1.2600.2930174,59215-Jun-200609:35x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terms that are used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
Keywords: 
kbautohotfix kbfix kbbug kbHotfixServer kbqfe KB918334
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support