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Article ID: 922120 - Last Review: May 22, 2013 - Revision: 9.0

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Symptoms

When you run Network Map on a Windows Vista-based computer, computers that are running Windows XP do not appear on the network diagram.

Note This article describes an update that will make 32-bit Windows XP-based computers appear in Network Map on Windows Vista-based computers. For more information about how to set up or to troubleshoot networking between Windows Vista and Windows XP, see the "More Information" section.

Cause

This problem occurs if the Link-Layer Topology Discovery (LLTD) Responder component is not installed on the Windows XP-based computer.

Network Map in Windows Vista makes network diagrams of the connections between network devices that can be used to troubleshoot connectivity problems. Network Map uses a discovery protocol called Link-Layer Topology Discovery (LLTD) that queries other devices on the network to determine how the network is organized.

Windows Vista includes the software components that implement the LLTD protocol. For other devices on the network to be displayed on the map, they must enable a discovery protocol that can respond to the mapping requests from the Windows Vista-based computer.

Resolution

Update information

The following file is available for download from the Microsoft Download Center:

Collapse this imageExpand this image
Download
Download the Link Layer Topology Discovery (LLTD) Responder package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=4F01A31D-EE46-481E-BA11-37F485FA34EA&displaylang=en)

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Hotfix for Windows XP Service Pack 3 (SP3)

To resolve this problem, install the hotfix that is described in this section. The hotfix installs the LLTD Responder component on Windows XP-based computers.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP SP3 installed on a 32-bit computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Update replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatformSP requirement
Rspndr.exe5.1.2600.561110,75229-May-200812:04x86SP3
Rspndr.sys5.1.2600.561162,84829-May-200812:04x86SP3

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about how to set up or to troubleshoot networking between Windows Vista and Windows XP, visit the following Microsoft Web sites.

How to troubleshoot network connection problems

http://windowshelp.microsoft.com/Windows/en-us/help/33307acf-0698-41ba-b014-ea0a2eb8d0a81033.mspx (http://windowshelp.microsoft.com/Windows/en-us/help/33307acf-0698-41ba-b014-ea0a2eb8d0a81033.mspx)

Windows Vista networking

http://windowshelp.microsoft.com/Windows/en-us/networking.mspx (http://windowshelp.microsoft.com/Windows/en-us/networking.mspx)

File and printer sharing in Windows Vista

http://technet.microsoft.com/en-us/library/bb727037.aspx (http://technet.microsoft.com/en-us/library/bb727037.aspx)

How to share and to set permissions for folders and for files by using Windows XP

http://technet.microsoft.com/en-us/library/bb456988.aspx (http://technet.microsoft.com/en-us/library/bb456988.aspx)
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates
If the resources that are listed in this section do not help you resolve the problem, or if you experience symptoms that differ from those that are described in this article, search the Microsoft Knowledge Base for more information. To search the Microsoft Knowledge Base, visit the following Microsoft Web site:
http://support.microsoft.com (http://support.microsoft.com)
Next, type the text of the error message that you receive or a description of the problem in the search box.

Note If the problem is not resolved, unfortunately this content is unable to help you any further. Therefore, you might want to ask someone for help, or you might want to visit the following Microsoft Web site:
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

Applies to
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbresolve kbwinxppresp3fix kbbug kbfix kbHotfixServer kbqfe KB922120
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