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Article ID: 924692 - Last Review: August 29, 2007 - Revision: 2.1

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SYMPTOMS

On a Microsoft Windows XP-based computer, you use a high-bandwidth USB 2.0 device, such as an isochronous video camera. However, after you repeatedly start and stop the USB device, it stops working correctly. This problem is more likely to occur on a system that has 256 megabytes (MB) of RAM or less. However, when the system is under heavy stress, this problem may also occur on a system that has more than 256 MB of RAM.

When this problem occurs, you may receive an error message that resembles the following:
Creation of the video preview failed.
After this problem occurs, the USB device may be marked with a yellow exclamation point in Device Manager. Additionally, other USB 2.0 devices may not enumerate correctly, may not work correctly, or both.

CAUSE

This problem is caused by a bandwidth leak in the USB 2.0 bus.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Usbehci.sys5.1.2600.299330,20811-Sep-200609:00x86SP2SP2QFE
Usbohci.sys5.1.2600.299317,15211-Sep-200609:00x86SP2SP2QFE
Usbport.sys5.1.2600.2993143,48811-Sep-200609:00x86SP2SP2QFE
Usbuhci.sys5.1.2600.299320,60811-Sep-200609:00x86SP2SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915  (http://support.microsoft.com/kb/816915/ ) New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbfix kbbug kbwinxpsp3fix kbwinxppresp3fix kbhotfixserver kbqfe kbexpertisebeginner KB924692
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