DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 926145 - Last Review: January 25, 2007 - Revision: 1.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

SYMPTOMS

When you subscribe to project alerts in Microsoft Visual Studio 2005 Team Foundation Server, you receive the following error message:
TF50304 There is a syntax error in the subscription condition. Check the syntax.

CAUSE

This problem occurs when the display name of the project alerts recipient contains one apostrophe (').

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Visual Studio 2005. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
929697  (http://support.microsoft.com/kb/929697/ ) How to obtain the latest Visual Studio 2005 service pack

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Visual Studio 2005 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Microsoft.TeamFoundation.WorkItemTracking.Controls.dll8.0.50727.239606,20803-Nov-200607:46

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Visual Studio 2005 Service Pack 1.

MORE INFORMATION

Steps to reproduce the problem

  1. In Team Explorer, click the File menu, click New, and then click Team Project.
  2. Type TestProject, and then click Next.
  3. On the next three pages, click Next, and then click Finish.
  4. After the project is created, click Close.
  5. In Team Explorer, right-click TestProject, and then click Project Alerts.
  6. In the Project Alerts dialog box, click to select the check boxes for the project alerts that you want.
  7. Under Send to, type the e-mail address of a user who has one apostrophe in his or her display name.
  8. Click OK.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Visual Studio 2005 Team Foundation
  • Microsoft Visual Studio 2005 Team Foundation Server
Keywords: 
kbfix kbbug kbhotfixserver kbqfe kbpubtypekc KB926145
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support